0

Newly created JSS app when started in the disconnected mode as below, tries to consume layout service and fails to load the page

enter image description here

enter image description here

what could be causing this. tried creating fresh app multiple times, but the same issue occurs.

tried another fresh app this morning below is the error.

enter image description here

  • Please check your JSS version and Sitecore compatibility. Also, its not required but can you try setting up the API KEY , follow the jss docs for information on that. – Abhay Dhar Oct 21 at 7:46
  • @AbhayDhar - i just want to run the app in disconnected mode for now. I believe Sitecore is not required to run app in disconnected mode. – nari447 Oct 21 at 8:22
  • what is your jss version ? – Abhay Dhar Oct 21 at 9:25
  • it is version 12.0.0 – nari447 Oct 22 at 6:09
  • for the second screenshot , please check if any errors are there during app creation. This looks like if you are behind corporate proxy/firewall , you need to set up npm with proxy and username/pswd information – Abhay Dhar Oct 22 at 6:40
0

From the first error screenshot, issue is more look like of the firewall or port related issue.

JSS is somehow unable to connect on localhost:3042 which is a proxy server (act as Sitecore server in disconnected mode). Please check if this port is already in use or whether any firewall rules are getting applied.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.