4

I have created a workflow and two roles - author & approver. Also assigned permissions for the respective workflow states to each role.

There are 4 Workflow states:

Draft
 |_Submit
Awaiting Approval
 |_Approve
 |_Reject
Awaiting Publish
 |_Publish
 |_Reject
Done
 |_Auto Publish

For the author, there is access to only Draft & this is working fine.
For the approver, it has access as below:

enter image description here

When logged in as the approver, I'm expecting to see the Approve button, but I see this.

enter image description here

I have assigned Workflow Delete, command execute permissions also to each of the states:

enter image description here What is wrong with the permissions here.

UPDATE:

Following @MarkCassidy's instruction, I have applied the permissions to the root node & all the child states then had the same. But still, it doesn't change. When I log in as admin, I can see the Approve button.

Also, the approver role has read permissions to the website content root node.

enter image description here

enter image description here

2
+50

Mind the error message in yellow "You cannot edit this item because you do not have write access to it".

You also have to have Write permission allowed for items below "Blogs" item in order to use workflow states. It is not enough to have Workflow State Write or Workflow Command Execute permissions for your approver role.

  • I added the write permission for the approver role for the root content node and there is a change. The approve & reject buttons now show up but they are greyed out. It says you must lock this item to edit. – Qwerty Nov 4 at 9:59
  • You need to hit "Lock & Edit" in upper Ribbon and then buttons will be available. You can also disable required locking and editing by following this guide -> sitecore.stackexchange.com/questions/7809/… – Peter Procházka Nov 4 at 10:04
  • Basically user needs to lock this version for himself/herself and then either change content or hit Workflow Command like approve. This is how Sitecore works for "regular" content editors. Admins do not need to lock & edit. But you do not want to have all editors as admins... – Peter Procházka Nov 4 at 10:06
  • I wanted a permission where the approver should not be able to edit. He should just approve/reject. But in this case, he has to click on edit and also has the option to edit the content. Please suggest an alternative to what I'm looking for. – Qwerty Nov 4 at 10:10
  • It is not possible without Write permissions unfortunately. Take a look in this doc article -> doc.sitecore.com/users/90/sitecore-experience-platform/en/… . It says "The item is now in the next workflow state and new workflow commands are available in the notification bar. If you do not have permission to edit the item in the current workflow state, you cannot lock the item for editing and the workflow commands are not displayed." – Peter Procházka Nov 4 at 10:13
6

The the role to see the actions, you have to assign the permissions at the action level. Without that, the role will be denied the permissions to see the action.

enter image description here

  • But I gave permissions to the root node with read & write descendants. Why isn't that applying. – Qwerty Oct 28 at 5:00
  • Workflows are different items. You need to assign Workflow Command Execute and Workflow State Write – Chris Auer Oct 29 at 1:02
4

Further to what Chris already said; it helps if you expand the security view. Click "Columns" in your Security Editor, and bring in the additional columns you need to look out for.

enter image description here

  • Following your instruction, I have set those to the parent node (Corlate Workflow). Then I checked each state & all of them had the same. But still it does not change. When I log in as admin, I can see the Approve button. Please check the snap in the update. – Qwerty Nov 4 at 9:25
  • 1
    Do you have permission on the item that you are trying to edit? Does the role have read and write access on the item and parent node? Can you please verify and let us know? – Sumit Upadhyay Nov 4 at 9:42
  • @SumitUpadhyay, I just confirmed & the role does have permissions to the root node of all the content. Also attached the snap. Please check. – Qwerty Nov 4 at 9:55
1

Can you please check in Access viewer that no other role is overwriting the permissions you have assigned (specially workflow related permissions).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.