1

I tried setting up a <site> element on my Project layer with parameters requiredLogin="true" loginPage="/Login" domain="extranet"

I also have granted these items with Read access:

sitecore/content/SiteItem

sitecore/content/SiteItem/Home

sitecore/content/SiteItem/Home/Login

when I try to visit the page via {url}/Login it redirects me to the default Sitecore login page.

Am I missing some steps here?

  • can you try setting the full item path e.g. loginPage="/sitecore/content/SiteItem/Home/Login" – josedbaez Oct 29 '19 at 15:33
  • @josedbaez same result, however when my property is loginPage="/login" the redirect Url is {url}/sitecore/login?returnUrl=404 (something like that) so the redirect works, it's just that the read access doesn't seem to not be taking effect – Lala Oct 29 '19 at 15:40
  • does extranet/anonymous user have access to login item? – josedbaez Oct 29 '19 at 15:44
  • Have you tried clearing cache/cookies or in an incognito window? – jammykam Oct 29 '19 at 15:51
  • yes, extranet/anonymous has Read access to login item – Lala Oct 29 '19 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.