1

I only installed Sitecore JavaScript Services Server for Sitecore 9.1.1 XP 11.1.0 rev. 190508.zip to check Layout Services and nothing else.

My jss layout service is absolutely working fine with url

http://sc91.local/sitecore/api/layout/render/jss?item=/&sc_apikey={key}

from the browser and Postman. I got the response as below.

{"sitecore":{"context":{"pageEditing":false,"user":{"domain":"sitecore","name":"admin"},"site":{"name":"website"},"pageState":"preview","language":"en"},"route":{"name":"Copy of Home","displayName":"Copy of Home","fields":{"Text":{"value":"<p>For further information, please go to the <a rel=\"noopener noreferrer\" href=\"https://doc.sitecore.net/\" target=\"_blank\" title=\"Sitecore Documentation site\">Sitecore Documentation site</a></p>"},"Title":{"value":"Copy of Home Sitecore Experience Platform"}},"databaseName":"master","deviceId":"fe5d7fdf-89c0-4d99-9aa3-b5fbd009c9f3","itemId":"b34735c1-ae9c-4098-92d9-74868859daac","itemLanguage":"en","itemVersion":1,"layoutId":"14030e9f-ce92-49c6-ad87-7d49b50e42ea","templateId":"76036f5e-cbce-46d1-af0a-4143f9b557aa","templateName":"Sample Item","placeholders":{}}}}

When i add personalization rule to the item, i didn't find any change in response.

I added tracking=true as well but no change. i.e. http://sc91.local/sitecore/api/layout/render/jss?item=/&sc_apikey={key}&tracking=true

i got visitorIdentificationTimestamp":637088102292400969 value in the response but no change into the field values.

There is nothing special in the rule. i configured it for "where true (actions always execute)" and changed the datasource or just hide the component itself.

Ideally it should return the changed datasource content but it is returning the original content only.

Note: It includes only those fields that are into the context item and not what datasource items have. Even i don't find any placeholder in the response.

Edit 1:

Sitecore 9.1 Update 1

License: xDB enabled

xDB settings: Default/No Change

Am i doing something wrong?

  • 1
    What you're not telling us are the details we need to know. Is it an XM or XP install? Is your license enabled for xDB? What are the xDB related settings for tracking? – Mark Cassidy Nov 8 at 15:40
  • Added environment deatils – Arvind Gehlot Nov 8 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.