2

Sitecore PowerShell Extensions 5.1.0.19766

Sitecore 9.1

Windows PowerShell 5.1

I want to view the Objects during a debug process by hovering over the variable, object, array, etc., but only see a tiny (very tiny) box. Below are two screenshots 1st of the issue and 2nd of a previous version of SPE in Sitecore 8.1.3 where the doesn't exist. How do I fix this?

enter image description here

enter image description here

5
  • Did you upgrade from a previous version? Clear the browser cache? Nov 13 '19 at 2:01
  • @MichaelWest yes, I've cleared my cache, rebooted, etc.
    – LReeder14
    Nov 14 '19 at 14:32
  • @MichaelWest - this is still an issue and it is seriously hampering my debugging of scripts. I've cleared cache, rebooted, etc. I have Powershell ISE (Windows 10) installed and it's not an issue there. Is there a setting that perhaps needs tweaked?
    – LReeder14
    Feb 12 '20 at 17:48
  • 1
    Do you have the Identity Server config enabled like described here? sitecore.stackexchange.com/a/18775/95 Feb 12 '20 at 18:06
  • @MichaelWest - Fantastic! I simply renamed the file referenced there: "\App_Config\Include\Cognifide.PowerShell.IdentityServer.config.disabled" removed the ".disabled" and now I have my debug context showing. Thank you very much! By the way, that was on my local instance, not our QA or Prod instance, so I'll need to carefully approach those with that change.
    – LReeder14
    Feb 12 '20 at 18:33
2

Per Michael West's comment, the solution for my local instance was Rename this file removing the .disabled:

\App_Config\Include\Cognifide.PowerShell.IdentityServer.config.disabled

1

In a Sitecore docker instance the fix is pretty much the same as @LReeder14 said except that the file has been renamed and moved to a new path. In the CM container one should look for the path App_Config/Include/Spe and enable the file Spe.IdentityServer.config

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.