I am using Layout Services API call to get data from Sitecore. Layout Service API is working fine and I am getting a response back in json format.

My xDB is enabled and working fine for other activities and I can see those activities into Analytics and xProfiles.

I set some personalization rules for my page component but it is not working.

I went through the link https://jss.sitecore.com/docs/fundamentals/services/tracking mentioning possible cause for this issue. My situation is falling under 2nd point where it says that, if the value of SC_ANALYTICS_GLOBAL_COOKIE ends with |False, your analytics ID is flagged as a robot.

I am getting the value ends with False for all requests, even though I set all configuration values as per instructions and my indexing anonymous contacts value is also enabled.

Here is my config setting for JSS

<setting name="Analytics.AutoDetectBots" set:value="false" />
<setting name="Analytics.Robots.IgnoreRobots" set:value="false" />
<setting name="Media.AlwaysIncludeServerUrl" set:value="true" />
<setting name="Analytics.ForwardedRequestHttpHeader" set:value="X-Forwarded-For" />
<setting name="Sitecore.JSS.TrackerServiceEnabled" value="true" />

Any clue?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.