2

I am facing issue while this unconventional issue in the Sitecore Solr Master Slave configuration.

Below are the details.

Sitecore Version: Sitecore 8.2 Update 6

Solr Version: 6.4.0 (We are using this as previous vendor used this)

Hosting Platform: These all are in-premise VM's

  1. I have Master Slave Configuration for Solr to be in use for Sitecore.
  2. I have a Slave server pointed in CD and Master in CM.
  3. Our Site is working absolutely fine.
  4. But still, we are getting below error printed in Log files.
    
> 7860 09:46:24 Unable to connect to [http://slavesolrdomain:port/solr], Core: [sitecore_web_index] in Master Slave Solr Configuration
Exception: SolrNet.Exceptions.SolrConnectionException
Message: 

4040org.apache.solr.common.SolrExceptionorg.apache.solr.common.SolrExceptionCan not find: schema.xml [C:\solr\server\solr\sitecore_web_index\conf\schema.xml]404

> 
> Source: SolrNet
   at SolrNet.Impl.SolrConnection.Get(String relativeUrl, IEnumerable`1 parameters)
   at SolrNet.Impl.SolrBasicServer`1.GetSchema()
   at Sitecore.ContentSearch.SolrProvider.SolrSearchIndex.Initialize()
  1. I tried to access the Slave Solr admin panel from the browser on CD VM on and it is working fine I can go to the web index also.
  2. I also tried to create the item and publish it to this and it is also getting reflected.
  3. Only the thing which I am doing which is against the concept is Our Slave servers are connected to Load Balancer but I am accessing these directly with IPs in the CD server.

Please let me know if require any more information.

1

I got the answer for this issue and below steps I followed to resolve it.

  1. I was using NAT IP so I checked my host file for this.
  2. It was host file entry where the host entry was made to another IP.
  3. Then I removed all the Solr host entry for this.
  4. Then I checked the issues was not getting reproduced.
  5. I also changed it to come from LB and it also working fine.

So I can conclude that the issue was wrong host entry which was pointing to the Solr which was not having schema file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.