We have created a Catalog in Business Tool. But it is not showing after performing below activities:

  1. Bootstrap
  2. Clean Environment
  3. Initialize environment.

I forgot to export the catalog before doing the above mentioned activities.

Even when I tried to create a new catalog with the same name that we have earlier, it is saying:

Catalog name <_catalog_name> already in use

I tried to find the same catalog in the tables [sitecore_commerce_storage].[CatalogEntities] and [sitecore_commerce_storage].[CatalogLists]. I could not found the earlier newly created catalog.

Please can any one help me in either recovering the earlier created catalog or deleting the same so that I can create the same catalog again.

  • Setup Sitecore Commerce Postman sample APIs. After you setup. You should be able to view available catalogs, delete a catalog or create a new catalog. The Postman API samples should be helpful. Please, let us know if this approach works out. Commented Nov 24, 2019 at 15:50
  • Postman is configured on my machine. Please can you indicate which methods/api need to call from postman? it would be helpful for me.
    – Jitendra
    Commented Nov 25, 2019 at 9:48

3 Answers 3


Yes. Even if your Bootstrap/Clean Environment/Initialize environment through Postman API you might get into this error "Catalog name <_catalog_name> already in use" sometimes. Try flushing your Redis cache with help of "RedisDesktopManager" tool. It might solve your issue.

  • Sorry.. It did not resolved my issue.
    – Jitendra
    Commented Dec 30, 2019 at 18:16

I just completed a Sitecore Postman API sample setup tutorial. This should help. https://www.youtube.com/watch?v=QOMMXT3Fiy0&t=78s

If you did setup the Postman API samples you should see the "CatalogAPISamples" folder. There are many APIs that you can use.

enter image description here

Also if you set up the "Sitecore.Commerce.Engine.SDK.4.0.102.zip" on your local machine you should be able to debug and see what the problem is.

I have another Sitecore Tutorial that explains how to set up the local environment.


  • Thanks for your answer Ercan. But my postman is working perfectly fine and able to get the response as well. My problem is, cleaning up activity remove all the catalog from the business tool. I have not taken backup of the custom created catalog. I am back that catalog in the business tool.
    – Jitendra
    Commented Nov 26, 2019 at 6:22

Cannot recover catalog once you have triggered Clean Environment api from postman.

When you are trying to create Catalog with same name, it is show error as "Catalog name <_catalog_name> already in use" because this task might not be completed.

You can check command status "Check Long Running Command Status" with this api in postman.

To resolve this issue, run Clean Environment api and check status of it in "Check Long Running Command Status" with this api.

These steps have helped me to re-import catalog or re-create catalog without any issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.