1

We have deployed our Sitecore JSS Application to the CM and CD Server (Azure VM). The site is up and running but some js and css files in root/dist/$name folder are throwing 500 Internal Server Error. On turning on the assembly binding, we got detailed error message. It seems like sitecore is trying to find another application inside the /dist/$name folder.

re-bind state information ===
LOG: DisplayName = System.Web.Helpers, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
 (Fully-specified)
LOG: Appbase = file:///C:/inetpub/wwwroot/prod.project.com/dist/projectname/
LOG: Initial PrivatePath = C:\inetpub\wwwroot\prod.projectname.com\dist\projectname\bin
Calling assembly : (Unknown).
===
LOG: This bind starts in default load context.
LOG: No application configuration file found.
LOG: Using host configuration file: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet.config
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework64\v4.0.30319\config\machine.config.
LOG: Post-policy reference: System.Web.Helpers, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/Temporary ASP.NET Files/dist_projectnamedotcom/745292f1/65e808b9/System.Web.Helpers.DLL.
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/Temporary ASP.NET Files/dist_projectnamedotcom/745292f1/65e808b9/System.Web.Helpers/System.Web.Helpers.DLL.
LOG: Attempting download of new URL file:///C:/inetpub/wwwroot/prod.projectname.com/dist/projectnamedotcom/bin/System.Web.Helpers.DLL.
LOG: Attempting download of new URL file:///C:/inetpub/wwwroot/prod.projectname.com/dist/projectnamedotcom/bin/System.Web.Helpers/System.Web.Helpers.DLL.
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/Temporary ASP.NET Files/dist_projectnamedotcom/745292f1/65e808b9/System.Web.Helpers.EXE.
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/Temporary ASP.NET Files/dist_projectnamedotcom/745292f1/65e808b9/System.Web.Helpers/System.Web.Helpers.EXE.
LOG: Attempting download of new URL file:///C:/inetpub/wwwroot/prod.projectname.com/dist/projectnamedotcom/bin/System.Web.Helpers.EXE.
LOG: Attempting download of new URL file:///C:/inetpub/wwwroot/prod.projectname.com/dist/projectnamedotcom/bin/System.Web.Helpers/System.Web.Helpers.EXE.

enter image description here

To resolve this, we included /dist/$name folder in "IgnoreUrlPrefixes" but the error still persists. Please suggest a resolution.

  • did you also deploy the configuration file for the jss. It should be present in the zzz folder – Hishaam Namooya Nov 27 at 6:52
  • @HishaamNamooya Yes, we have deployed that config as well. – NewbieHere Nov 28 at 6:16
  • Can you please share the config file? – Hishaam Namooya Nov 28 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.