I installed Sitecore 9.3 and everything works fine, I didn't get any errors during installation.

I installed Horizon following the documentation.

I replaced all parameters from parameters.ps1 file.

I run install.ps1 and I didn't get any errors.

enter image description here

When I access the the Horizon Site I got the following error:

HTTP Error 502.5 - Process Failure

Common causes of this issue:
The application process failed to start
The application process started but then stopped
The application process started but failed to listen on the configured port

Troubleshooting steps:
Check the system event log for error messages
Enable logging the application process' stdout messages
Attach a debugger to the application process and inspect
  • Yes, I also faced same problem and solved after copied the licence file. Commented Nov 29, 2019 at 7:04

2 Answers 2


I verify first time the logs folder of Horizon and it was empty.

I run in the root site of the site next command :

dotnet Authoring.Host.dll and I received next error :

c:\inetpub\wwwroot\horizonsc93sc.dev.local>dotnet Authoring.Host.dll

Unhandled Exception: System.InvalidOperationException: License file doesn't exist on disk.
   at Sitecore.Framework.Runtime.Commands.SitecoreHostCommand.LoadLicenseXml(String filePath, String contentRootPath)
   at Sitecore.Framework.Runtime.Commands.SitecoreHostCommand.OnExecuteAsync(CommandLineApplication app)
   at McMaster.Extensions.CommandLineUtils.Conventions.ExecuteMethodConvention.InvokeAsync(MethodInfo method, Object instance, Object[] arguments) in C:\projects\commandlineutils\src\CommandLineUtils\Conventions\ExecuteMethodConvention.cs:line 77
   at McMaster.Extensions.CommandLineUtils.Conventions.ExecuteMethodConvention.OnExecute(ConventionContext context) in C:\projects\commandlineutils\src\CommandLineUtils\Conventions\ExecuteMethodConvention.cs:line 62
   at McMaster.Extensions.CommandLineUtils.Conventions.ExecuteMethodConvention.<>c__DisplayClass0_0.<<Apply>b__0>d.MoveNext() in C:\projects\commandlineutils\src\CommandLineUtils\Conventions\ExecuteMethodConvention.cs:line 25
--- End of stack trace from previous location where exception was thrown ---
   at McMaster.Extensions.CommandLineUtils.CommandLineApplication.<>c__DisplayClass126_0.<OnExecute>b__0() in C:\projects\commandlineutils\src\CommandLineUtils\CommandLineApplication.cs:line 505
   at McMaster.Extensions.CommandLineUtils.CommandLineApplication.Execute[TApp](CommandLineContext context) in C:\projects\commandlineutils\src\CommandLineUtils\CommandLineApplication.Execute.cs:line 31
   at McMaster.Extensions.CommandLineUtils.CommandLineApplication.ExecuteAsync[TApp](CommandLineContext context) in C:\projects\commandlineutils\src\CommandLineUtils\CommandLineApplication.Execute.cs:line 145
   at McMaster.Extensions.CommandLineUtils.CommandLineApplication.ExecuteAsync[TApp](IConsole console, String[] args) in C:\projects\commandlineutils\src\CommandLineUtils\CommandLineApplication.Execute.cs:line 130
   at Sitecore.Program.<Main>(String[] args)

Looks like the license wasn't copy it into the right folder.

When I copy the license file into the folder: c:\inetpub\wwwroot\horizonsc93sc.dev.local\sitecoreruntime\ the Horizon editor start working.


After copying the license file into the following folder resolved my issue : When I copy the license file into the folder: c:\inetpub\wwwroot\horizonsc93sc.dev.local\sitecoreruntime\

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.