2

I've installed Sitecore 9.3 and it is all working fine, I didn't get any errors during installation. After that, I follow the documentation and replaced all parameters in parameters.ps1 file. But when I run install.ps1 I got below Error -

Install-SitecoreConfiguration : The response content cannot be parsed because the Internet Explorer engine is not
available, or Internet Explorer's first-launch configuration is not complete. Specify the UseBasicParsing parameter
and try again.
At D:\scdumps\sc93\Sitecore Horizon 9.3.0\Public\Install-FeatureIntegrationPackage.ps1:92 char:5
+     Install-SitecoreConfiguration @sitecoreCM -WorkingDirectory $wrkm ...
+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:12
Invoke-WebRequest : The response content cannot be parsed because the Internet Explorer engine is not available, or
Internet Explorer's first-launch configuration is not complete. Specify the UseBasicParsing parameter and try again.
At D:\scdumps\sc93\Sitecore Horizon 9.3.0\Extensions\sitecore-cm.psm1:62 char:9
+         Invoke-WebRequest -Uri $siteURL -TimeoutSec 600
+         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotImplemented: (:) [Invoke-WebRequest], NotSupportedException
    + FullyQualifiedErrorId : WebCmdletIEDomNotSupportedException,Microsoft.PowerShell.Commands.InvokeWebRequestComman
   d

enter image description here

4

The error was showing that the Internet Explorer engine is not available. But I had installed this on my system from the beginning. So try to find some other solutions and most of them were saying to update the exiting script by adding -UseBasicParsing parameter. Since I was installing Horizon first time so I was afraid of updating this.

But real problem was that Internet Explorer Browser was not launched properly on my system, every time I launched IE it was asking me for the first-launch configuration and I always clicked on ask me later. All we need to set this configuration and click "Ok". I will recommend selecting the recommended setting from the dialog box-

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.