2

SIA is not able to validate my install do to not having SIF configuration checked off on validation page, everything else installs with not issues and the log files are empty after letting SIA install prerequisites. I have ran SIA as administrator with not change, IIS is installed along with SQL Server. When attempting to install configuration via Powershell this is the only error(s) I receive is:

Install-SitecoreConfiguration : Unable to parse [ResolveCertificatePath(variable('Security.XConnect.CertificatePath'))] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [joinpath(variable('Security.CertificateStore'), variable('Security.XConnect.CertificateThumbprint'))] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [GetCertificateThumbprint(parameter('XConnectCert'), variable('Security.CertificateStore'))] - Exception calling "InvokeWithContext" with "2" argument(s): "Cannot bind argument to parameter 'Id' because it is an empty string.""" At line:1 char:1 + Install-SitecoreConfiguration + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:06 GetConfigFunctionResult : Unable to parse [ResolveCertificatePath(variable('Security.XConnect.CertificatePath'))] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [joinpath(variable('Security.CertificateStore'), variable('Security.XConnect.CertificateThumbprint'))] - Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: Unable to parse [GetCertificateThumbprint(parameter('XConnectCert'), variable('Security.CertificateStore'))] - Exception calling "InvokeWithContext" with "2" argument(s): "Cannot bind argument to parameter 'Id' because it is an empty string.""" At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.2.0\Private\JsonConfiguration.ps1:226 char:20 + ... return GetConfigFunctionResult -FunctionText $InputObject -Param ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,GetConfigFunctionResult

The prerequisites log file is the only one with anything in it and is as follows:

The property 'FullName' cannot be found on this object. Verify that the property exists. The property 'FullName' cannot be found on this object. Verify that the property exists. The property 'FullName' cannot be found on this object. Verify that the property exists. The property 'FullName' cannot be found on this object. Verify that the property exists. The property 'FullName' cannot be found on this object. Verify that the property exists. ************************************ Sitecore Install Framework Version - 2.2.0 ************************************

WorkingDirectory : \Mac\Home\Downloads\Sitecore 9.3.0 rev. 003498 (Setup XP0 Developer Workstation rev. 1 WhatIf : False Verbose : SilentlyContinue Configuration : \Mac\Home\Downloads\Sitecore 9.3.0 rev. 003498 (Setup XP0 Developer Workstation rev. 1\Prerequisites.json Debug : SilentlyContinue AutoRegisterExtensions : False WarningAction : Continue ErrorAction : Stop InformationAction : Continue

[-- DownloadVisualC++2015x86 [Skipped] : DownloadFile ------------------------]

[--------- InstallC++2015x86 [Skipped] : StartProcess ------------------------]

[-- DownloadVisualC++2015x64 [Skipped] : DownloadFile ------------------------]

[--------- InstallC++2015x64 [Skipped] : StartProcess ------------------------]

[----------- SQLServerModule [Skipped] : InstallModule -----------------------]

[--------------------- WindowsFeatures : EnableWindowsOptionalFeature --------]

[ DownloadWebPlatformInstaller [Skipped] : DownloadFile ------------------------]

[ InstallWebPlatformInstaller [Skipped] : StartProcess ------------------------]

[------- InstallWebDeploy3.6 [Skipped] : StartProcess ------------------------]

[-------- InstallURLRewrite2 [Skipped] : StartProcess ------------------------]

[---- DownloadSQLClrTypesx86 [Skipped] : DownloadFile ------------------------]

[----- InstallSQLClrTypesx86 [Skipped] : StartProcess ------------------------]

[---- DownloadSQLClrTypesx64 [Skipped] : DownloadFile ------------------------]

[----- InstallSQLClrTypesx64 [Skipped] : StartProcess ------------------------]

[ DownloadSQLDacFrameworkx86 [Skipped] : DownloadFile ------------------------]

[- InstallSQLDacFrameworkx86 [Skipped] : StartProcess ------------------------]

[ DownloadSQLDacFrameworkx64 [Skipped] : DownloadFile ------------------------]

[- InstallSQLDacFrameworkx64 [Skipped] : StartProcess ------------------------]

[----------- DownloadSQLODBC [Skipped] : DownloadFile ------------------------]

[------------ InstallSQLODBC [Skipped] : StartProcess ------------------------]

[ DownloadDotNetMultiTargeting [Skipped] : DownloadFile ------------------------]

[ InstallDotNetMultiTargeting [Skipped] : StartProcess ------------------------]

[--- DownloadDotNetFramework [Skipped] : DownloadFile ------------------------]

[---- InstallDotNetFramework [Skipped] : StartProcess ------------------------]

[------------------ IISReset [Skipped] : StartProcess ------------------------]

[-------------------------- InformUser : WriteInformation --------------------] Sitecore prerequisites are now installed, YOU MUST launch a new PowerShell session to run further SIF configurations. [TIME] 00:00:14

And i have ran powershell afterwards to ensure that everything is installed but still have a red X next to SIF

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.