I'm upgrading from 9.0.2 (XM) to 9.2 (XP), so I got a fresh install of the XDB enviroments (Azure WebApps), but my xcollect, ma-ops, xc-search (Solr), and maybe other webapps give me the You do not have permission to view this directory or page. error. Upon checking the application logs, it returns a single line:

[Error] Service can not be found: Sitecore.Xdb.Collection.Data.SqlServer.Configuration.ColumnEncryptionKeyStoreProviders.KeyStoreProviders, Sitecore.Xdb.Collection.Data.SqlServer

I've checked the certificates if they were correct as described in the following post: http://codeconcerns.com/sitecore-9-2-installation-errors-out-while-runnings-marketing-automation-service/

I've checked the connection strings and added the 'invalid client certificate allowed' as well (xConnect WebApps on Azure PaaS not working).


2 Answers 2


An answer has also been given through the Sitecore Community Slack channel.

Credit to sumithpd (Sr. Product Manager - Experience Platform at Sitecore) The mentioned class has been removed from the assembly, but it is still referenced in the configuration. It doesn’t affect any functionality since the class was obsolete for some time, and the log errors can be safely ignored! This issue is fixed in 9.3.

If you wish to get rid of the error from the logs, simply comment out line 99-103 of the App_data/Config/Sitecore/Collection/sc.Xdb.Collection.Data.Sql.xml file. You can also disable the App_data/Config/Sitecore/CoreServices/sc.Xdb.Sql.Common.Encryption.xml file.


This looks like SQL encryption using column encryption keys is enabled, but possibly the way in which this is configured in 9.2 is different from 9.0.2, or the encryption keystore on your xConnect instance has not been configured. If you previously had encryption using column encryption keys and a keystore or Azure KeyVault, you might need to reconfigure your settings for the new instance. For Windows Keystore, follow the instructions here.

  • 2
    Thanks for the answer andyp. This would be indeed an option if we would have Column Encryption enabled. But this is not the case. This is done with clean deploy packages for 9.2, and the databases are new as well (for XDB). Dec 4, 2019 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.