3

I have installed Sitecore 9.3 XP Single on Azure using Sitecore Experience Cloud (Azure Marketplace). Now I want to install Sitecore Horizon 9.3 on existing Azure Sitecore 9.3 instance.

While deploying, got an error that is Set-SCAzureDeployParameters command not recognize. I am unable to figure out this command is part of which power-shell module. Could you please advise on this?

enter image description here

3

Thanks Abhay for quick response. I overlooked the below steps from installation guide. After Unblocking the zip and unzip the Sitecore Azure Toolkit, then it started working fine.

enter image description here

0

I can see two errors when you are running the Deployhorizon.ps1.

  1. Remove-Item - cannot find path - Make sure you are running powershell in administrator mode
  2. The term 'Set-SCAzureDeployParameters' is not recognized as the name of cmdlet - This error generally means that there is an issue in either the name of the file in the path or the path itself is wrong.I would also check the paths set in the params $resourcegroupname, $licensexml ,$parameterspath and $sitecoreazuretoolkit
0

There are several errors in Sitecore's Azure toolkit. Main thing with your problem is that in the file "Sitecore.Cloud.Cmdlets.psm1" there is a try/catch/finally which tries to delete a temp file in the finally block, but does not check for it's existence before trying to delete. This causes you to see that error, but in fact you are most likely getting an error from the actual deployment which is not shown due to the bad implementation.

Try doing this in the "Sitecore.Cloud.Cmdlets.psm1" file's "finally" section (and also report it as yet another error to Sitecore support):

if ($paramJsonFile) {
    if(Test-Path -Path $paramJsonFile)
    {
        Remove-Item $paramJsonFile
    }
  }

Also be aware that Sitecore are using the legacy version of the Azure powershell module, so if you as I am, are using the AZ module, you have to enable AzureRM alias support : see here : https://docs.microsoft.com/en-us/powershell/module/az.accounts/enable-azurermalias?view=azps-3.7.0

Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.