3

We are using Sitecore 9.0 update 1 and have run into an issue where one of our commerce items has been marked as Orphaned in the content editor, however in Commerce biz tools the item has parent associations. We have run a database clean, updated commerce cache, cleared sitecore caches, rerun main indexes and reset iis and the item still persists.

I cannot find it in the actual SQL database anywhere either for master or web. Is there another cache or file that Sitecore reads from to populate items in the content editor?

A few extra notes:

  1. When we re-index the sitecore master index, the item will get pulled in.

  2. We cannot browse to the item, but if we search for the ID itself, it will show a path of [orphan]/itemname when we hover over it. When clicking on the item, it shows the Sitecore root node information.

4

Try this: 1-From BizFx: Disassociate this product/sellableItem from all parents (Take note of them before you disassociate). 2-Go to Sitecore Content Editor: Clear Commerce Cache. 3-Verify that at this step the item no longer exist in the content-tree. 4-Go back to Bizfx and re-associate the product to its parents. 5-Clear Commerce Cache. 6-Verify that item is showing properly.

I think the ParentCategoryList and ParentCatalogList of the product json entity might be messed-up. If that's the case, Disassociating and re-associating should fix the issue.

2
  • Thank you! This was absolutely the problem – AdmanStrong Dec 8 '19 at 13:58
  • You're welcome. Glad it worked :-) – Yassine Alahyane Dec 9 '19 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.