0

I followed this article to create a custom email template: https://doc.sitecore.com/developers/exm/90/email-experience-manager/en/walkthrough--building-a-custom-message-template.html

However, it's not showing up in the EXM dialog. Any suggestions/insights? Sitecore version 9.2, EXM version 3.5.1 rev. 171103

enter image description here

  • Have you performed this action: In the Insert Options dialog, navigate to your message template, for example, /templates/Branches/System/Email/Messages/Custom Newsletter/Monthly Newsletter and add it to the Selected pane. – Swati Gupta Dec 10 '19 at 5:15
  • In this path: "/sitecore/templates/Branches/System/Email/Manager Root", for the message types I have added the newly created template to the insert options. Still not working – ashesh Dec 10 '19 at 15:18
2

Have you add the custom template to this item's Insert Option ? /sitecore/content/*EXM Email Manager Root*/Message Types/Regular/Default

/sitecore/content/EXM Email Manager Root/Message Types/Regular/Default Insert Option

Publish the item. Then it should appear in the EXM Regular Template Option

EXM Regular Template Option EXM Regular email campaign

| improve this answer | |
  • thank you so much for your suggestion!! – ashesh Dec 11 '19 at 16:05
0

Since we have multi site implementation, I had to go to each site's Email Manager Root and assign the template to the insert options. i.e. here in .../Emails/Message Types/Automated/Default I added the newly created email template to the insert option for Default and it worked!!

enter image description here

Thanks to all who helped from the slack.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.