2

For some search requests to SOLR 7.2.1 I have to use quite long queries (oversees 8192 symbols), as a result I'm getting (414) URI Too Long error.

I've already investigated many articles and tried solutions from them, but any doesn't help:

  1. https://wcms.clearpeople.com/insights/blog/2017/june/using-post-to-communicate-with-solr-from-sitecore

  2. https://vicent.dev/post/2017/04/28/Using-POST-to-communicate-with-Solr-from-Sitecore

  3. ContentSearch Solr SendPostRequests settings throw exception

Is there any working solution for Sitecore 9.1 and Solr 7.2.1?

  • 1
    You seen this already? – Debabrata Biswas Dec 10 '19 at 14:44
  • Yes, I saw it, but it does not suit our needs. – Artur Yakimovich Dec 11 '19 at 8:23
  • but we can send a POST request to SOLR without sitecore , is there any dependecny on using Sitecore for the POST request ? – Abhay Dhar Dec 11 '19 at 9:50
2

I've finally got an answer from Sitecore Support - unfortunately there is no way to send POST requests to Solr (7.2.1) from Sitecore (at least 9+). Hope it will be fixed soon, but as of now - there is an official response:

Thank you for contacting our support team. From the provided description, it looks like you've faced a bug with reference number 288837, because of which setting "ContentSearch.Solr.SendPostRequests" does not work with value "true". More information about public reference numbers can be found here: https://kb.sitecore.net/articles/853187

According to our tickets history, changing the "ContentSearch.Solr.SendPostRequests" value to "false" and increasing a header size as per the mentioned by you KB article is the only known workaround at the moment.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.