0

I am getting an error when I click on the updates tab. the error that I get is

The packages cannot be loaded. View details

When I click view details links, I see the below error message :

An error occurred when trying to create a controller of type PackageManagementController. Make sure that the controller has a parameterless public constructor.

enter image description here

Can someone please help?

  • What is your Sitecore version and is there any error in log? – Mahendra Shekhawat Dec 11 '19 at 5:44
0

Make sure you have the following in the ConnectionStrings.config

<add name="PackageManagementServiceUrl" connectionString="https://updatecenter.cloud.sitecore.net/"/>

You can find more information here: https://doc.sitecore.com/developers/90/platform-administration-and-architecture/en/the-update-center.html

| improve this answer | |
0

If you have version 9.0.2 - 9.1.1, maybe, you need to update Sitecore Update Installation Wizard. You can find the package on https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform/91/Sitecore_Experience_Platform_91_Update1.aspx

For 9.0.2: Sitecore Update Installation Wizard for 8.x-9.0

For 9.1 and 9.1.1: Sitecore Update Installation Wizard for 9.1

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.