0

We have started indexing contacts by using Helpfulcore.AnalyticsIndexBuilder due to some reason we would like to stop contact indexing forcefully. May I know how can we stop indexing in Sitecore.

1
  • this is for which version you want to stop Dec 16 '19 at 2:29
0

To stop contact indexing from the external module you added to solution which is Helpfulcore.AnalyticsIndexBuilder you need to disable the below config file.

/App_Config/Include/Helpfulcore/Helpfulcore.AnalyticsIndexBuilder.config (add extension as .disabled)

If you are using Sitecore 8.2 Then to stop all contact Indexing you need to follow below.

  1. Go to the \App_Config\Include\Sitecore.ContentSearch.Analytics.config file.

  2. Set the "ContentSearch.Analytics.IndexAnonymousContacts" setting value to "false".

    <setting name="ContentSearch.Analytics.IndexAnonymousContacts" value="false"/>

If you are using Sitecore 9XP Then to stop all contact Indexing you need to follow below.

  1. Open the xConnect Search Indexer sc.Xdb.Collection.IndexerSettings.xml configuration file. In a default on-premise deployment, the full path is

\<xConnect role root>\App_Data\jobs\continuous\IndexWorker\App_data\Config\Sitecore\SearchIndexer\sc.Xdb.Collection.IndexerSettings.xml

  1. Set IndexAnonymousContactData to false to disable indexing.

    <IndexAnonymousContactData>false</IndexAnonymousContactData>

  2. Rebuild the xDB search index.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.