1

We had originally configured our XP1 instance to communicate directly to a single SQL server and everything was working correctly. Before going live we update the SQL server to be part of a high availability cluster which changed the SQL server name.

Since the server was named differently we had to update all of our connection strings files to use the HA name. After doing that and restarting all of the services we are seeing an error in the xConnectCollection logs:

sitecore_xdb.collection.Shard1 is participating in an availability group and is currently not accessible for queries

This is the error you see when your connection strings are pointed directly at a server rather than the cluster name. I've verified that all of our connection strings are updated

2

After looking into this some more it turns out that the server name is a field that is stored in the shard databases and isn't updated when you alter connection strings.

You can either re install your shard databases or you can edit the fields directly: xxx.ShardMapManager._ShardManagement.ShardsGlobal xxx.Collection.Shard1._ShardManagement.ShardsLocal xxx.Collection.Shard0._ShardManagement.ShardsLocal

Once you've done this, restart your xConnect index service and rebuild your xconnect index.

I found these instructions helpful to resolve new errors that we saw regarding tokens: XConnect IndexWorker error "Tokens are incompatible, they have different set of shards."

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.