0

I've set a different port for the installation of solr 8.1.1

Using the SIA it seems to install ok but if I continue on with the installation I get:

enter image description here

If I go to Services I can see that it's not running. I click start and it says it is running. But then 20 or so seconds later it has stopped itself.

Looking at the log file there seems to be an error about a valid keystore.

enter image description here

I currently have existing sites using a different version of solr so I can't use the default port. Is there a trick to installing Sitecore 9.3 with Solr on a different port number? Was looking forward to the installation just working.

Edit - I have solr 7.2.1 running successfully currently.

Update: I have tried installing solr 8.1.1 myself following Chris Auer's answer on:

How to get Solr to run as a service?

It all seems successful - says that the service was installed successfully but then in services it is in a Paused state. If I click resume it just goes back to paused.

The only file in my logs folder is: enter image description here

Which looks totally different to what I installed via the SIA. enter image description here

Navigating to the url just says connection refused.

enter image description here

Trying to run the command manually gives me this error: enter image description here

I do have solr installed to c:\program files\bitnami - so it kind of looks like it's not handling the space in program files? But I'm not sure where this would be specified/fixed.

6
  • There is no dependency on Solr Port for Sitecore 9.3 installation, It seems like your Solr is not working properly, Please check for SSL certificate and Java version installation on your system. – Mahendra Shekhawat Dec 19 '19 at 8:35
  • The error logs say that , SOLR should be running on HTTPS Mode. – Abhay Dhar Dec 19 '19 at 10:31
  • Solr 7.2.1 is running no issues. Where should I be checking these things for 8.1.1 I just expected the SIA to set it up with no manual intervention. Have I missed some pre-requirement check? – Jen Dec 19 '19 at 21:57
  • I have confirmed that I'm running the required version Java. I have 1.8.0_202 – Jen Dec 19 '19 at 22:27
  • Did you check windows event logs.? any error logged there. Sometimes that will give additional info about the issue. – Gobinath Saminathan Dec 20 '19 at 21:11
0

I wrote a blog post awhile back stating that if you want to run multiple instances on the same machine you need to have a JAVA (JRE) version that will work with all the SOLR versions. Then, what you need to do is modify the following file (may be different in 9.3):

App_Config\Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config

Point to the port you want in the Sitecore instance you are installing. This will allow you to have multiple versions of SOLR on the same machine.

<!-- SERVICE BASE ADDRESS
    Base url of the Solr server. (minus any cores and minus a trailing slash)
-->
<setting name="ContentSearch.Solr.ServiceBaseAddress" value="http://localhost:8985/solr" />

Here is a link to the full blog post: https://sitecoresandbox.com/2018/04/06/install-multiple-instances-of-solr-for-sitecore-development/

1
  • The JRE version I already have is compatible with Solr 8.1.1 - I seem to be having Solr Installation issues - so I can't even get to the point of installing 9.3 :( But thanks. – Jen Dec 20 '19 at 2:17
0

So turns out Solr was not happy about being located under c:\Program Files\Bitnami. Changing to C:\Solr and the service installed.

However trying to install the solr service myself resulted in an invalid certificate error. So I tried again to use SIA to install the solr service newly and that was all good.

Also noting if you have a failed attempt - you need to delete the sql databases, otherwise you get errors about users already existing, you also need to cleanup if it fails after installing a service (in my case I had picked an expired license initially which wasn't picked up in validation).

Also discovered when SIA fails you only have the option to Close - you can't go back to retain all the information you entered in to tweak and try again.

Got there in the end! I'm sure this would have worked like a dream had I not had a space in the Solr Path initially - but it worked with Sitecore 9.1 and Solr 7.2.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.