3

I am trying to follow up https://kb.sitecore.net/articles/889655 but as soon as I modify - publishing service would not start with the following error:

"[Error] Unable to start service: "Invalid schema version installed. Upgrade from version 0 to 1

Please run the 'Sitecore.Framework.Publishing.Host.exe schema upgrade' command to upgrade"

Sitecore.Framework.Publishing.Exceptions.InvalidSchemaVersionException: Invalid schema version installed. Upgrade from version 0 to 1

Please run the 'Sitecore.Framework.Publishing.Host.exe schema upgrade' command to upgrade

at Sitecore.Framework.Publishing.PublishingExtensions.EnsureLatestSchemaInstalled(IApplicationBuilder builder, ILogger logger)

at Sitecore.Framework.Publishing.Host.Startup.Configure(IApplicationBuilder app, ILogger`1 logger, IApplicationLifetime appLifetime, IServiceInformation serviceInformation) in C:\BA\fb80de5dfd630cfc\src\Sitecore.Framework.Publishing.Host\Startup.cs:line 87"

I executed schema upgrade --force prior to restarting a service with new configuration but still, the error is popping up.

enter image description here

4

Try to execute first Sitecore.Framework.Publishing.Host schema downgrade –-force and then execute Sitecore.Framework.Publishing.Host schema upgrade –-force

For me worked well few times.

3
  • I executed schema upgrade --force prior to restarting a service with new configuration but still, the error is popping up. Dec 23 '19 at 16:57
  • Did you try to execute it with schema downgrade --force and then again schema upgrade --force as I already mentioned above? Dec 23 '19 at 17:00
  • Thanks for double-checking to ensure I noticed the schema downgrade --force, and this make the trick! Thanks so much Dec 23 '19 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.