-1

I'm flowing the blog from "Viet Hoang" to install the Habitat.Home.Platform Docker example. I followed all the instructions and when I execute ".\build.ps1 -DeploymentTarget DockerBuild" the script is failing.

Could not load file or assembly 'file:///C:\sat\tools\Sitecore.Cloud.Cmdlets.dll' or one of its dependencies.

The package under the "sat" folder is the correct version ("Sitecore Azure Toolkit 2.4.0-r02514.1001") and the "Sitecore.Cloud.Cmdlets.dll" exists.

Previously, I did manage to run the Sitecore v9.3 Docker example and solved all the issues and verified Sitecore.

Sitecore v9.3 Docker - worked for me:
https://buoctrenmay.com/2019/11/12/playing-around-with-the-set-up-of-sitecore-docker-images/

Following this Blog - which is failing:
"https://buoctrenmay.com/2019/12/23/sitecore-xp-9-3-0-and-sxa-9-3-0-demo-habitat-home-setup-guide/"

Generate-Dacpacs
========================================
Executing: &"C:/Projects/Sitecore.HabitatHome.Platform/scripts/Packaging/generate-dacpac.ps1" -SitecoreAzureToolkitPath c:\sat -updatePackagePath c:\Deploy\update\package.update -securityPackagePath c:\Deploy\update\security.dacp
ac -destinationPath C:\Projects\Sitecore.HabitatHome.Platform\docker\images\windows\demo-xp-sqldev\Data
Cake.exe : An error occurred when executing task 'Generate-Dacpacs'.
At C:\Projects\Sitecore.HabitatHome.Platform\build.ps1:253 char:1
+ &$CAKE_EXE $cakeArguments
+ ~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (An error occurr...erate-Dacpacs'.:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError

Error: 
One or more errors occurred.

Could not load file or assembly 'file:///C:\sat\tools\Sitecore.Cloud.Cmdlets.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)


Does anybody know what might the missing Dependencies are?

3
  • Are you running it in PowerShell 6 (Core)? Try PowerShell or earlier, the blue one. – Alexander Doroshenko Jan 8 '20 at 15:30
  • * PowerShell 5 or earlier – Alexander Doroshenko Jan 8 '20 at 15:45
  • Hi. I'm using PowerShell 5.1. – Ercan Polat Jan 11 '20 at 4:43
1

Right-click on this file "C:\sat\tools\Sitecore.Cloud.Cmdlets.dll" and check the "Unblock Checkbox" and re-run the script.

This will solve this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.