Would there be any reason where a smart publish does not make an update but a republish does?


I recently updated my Sitecore 9.2 site. We have 2 production sites. 1 on, 1 off for switch overs. Each pointing to different databases. After updating the B (Off) site, turning it on, using Sidekick (migration tool) to make sure all items are the same as develop's admin panel, I noticed some things were not working on the B site.

Although the items (in sitecore admin panel) were the same from develop -> B site, on the actual site, they were not working. Then when trying to do a Smart publish, no items were updated, but the republish updated 2 items, for this particular issue and resolved this issue. I'm worried that there are still not working even though the items are synched properly.


Could the issue be after sidekick migration, rebuilding the db and reindexing were not done?

  • Have you run Sidekick in event disabler mode?
    – Marek Musielak
    Jan 10, 2020 at 21:22
  • Uncertain, what does that do? Jan 13, 2020 at 14:42

1 Answer 1


I did a Sitecore migration using the Sidekick module and experienced the same issue. The reason for this is because of the revision number of the item and/or you have the event disabled.

Smart publish mechanism is to compare items and it makes use of the revision field. If you are having none of the item being updated, this is because the revision number is the same.

If I am not mistaken, it is when you trigger the import that you'll see it is still having difference between the items. This is because the revision is different.


You will need perform a full publish but it will take time. In order to accelerate this one, I had made use of the Sitecore Publishing Service.

  • Is there a way to undo 'event disabled' on sidekick? if so, how? Thanks Jan 14, 2020 at 18:14
  • No unless you re-import the item. But it may happened that Sidekick won’t see the difference if the revision number is the same. Your main option here is to perform a Full site publish or do the publish node by node Jan 14, 2020 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.