In our solution we're using custom personalization rule to show/hide components based on some criteria. This rule works fine but only for the first time the user visits the page after it's published or Sitecore's cache is cleared.
Reloading the page, clearing browser cache, loging in as a difference user does not help - page is always rendered in a state that was encountered for the first time and the code for this rule isn't even executed.

We've tried different ideas like:

  • turning off caching everywhere we could find it (component's level, rendering, placeholders, settings for Site grouping item)
  • adding this personalization rule to components on partial design, page design and on a page itself
  • using built in Sitecore's personalization rules -> same weird behavior

1 interesting thing we've noticed - it seems to be working in Preview mode from Experience Editor. Rules are applied with every page reload.

We're using Sitecore 9.1.1 (rev 002459)

  • Is your custom rule getting hit after first visit? Have you tried setting a breakpoint there?
    – josedbaez
    Commented Jan 13, 2020 at 10:48
  • No, it's getting hit only on the first visit.
    – konw
    Commented Jan 13, 2020 at 12:01
  • Did you find a solution for this? I'm having the exact same issue. Commented Jul 16, 2021 at 11:46
  • We are using version Sitecore 10.1 and I don't see the "Ignore other caching..." checkbox. What setting should I be using instead? Here's what I see: (i.sstatic.net/K1AvQ.png)](https://i.sstatic.net/K1AvQ.png) Commented Oct 4, 2022 at 18:23

1 Answer 1


If you have caching set up on the rendering, then you need to sever the inheritance of the caching rules by ticking the below box on the rendering control. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.