1

I have a new Sitecore 9 vanilla install. I created a JSS site and entered the connected mode. Immediately I'm getting an error in the Experience Editor. On-screen I see:

An error occurred. [Log message: Value cannot be null. Parameter name: source]

And in the logs I see:

18856 17:04:35 ERROR Value cannot be null.
Parameter name: source
Exception: System.ArgumentNullException
Message: Value cannot be null.
Parameter name: source
Source: System.Core
  at System.Linq.GroupedEnumerable`3..ctor(IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer)
  at Sitecore.ExperienceEditor.Utils.ItemUtility.GetLockedItemsCount(String userName)
  at Sitecore.ExperienceEditor.Utils.ItemUtility.GetLockedItemsCountOfCurrentUser()
  at Sitecore.ExperienceEditor.Speak.Ribbon.Requests.MyItems.MyItemsCountRequest.ProcessRequest()
  at Sitecore.ExperienceEditor.Speak.Server.Requests.PipelineProcessorRequest`1.Process(RequestArgs requestArgs)

I checked the locked items in the control panel and nothing is locked. Not sure why this method is failing

  • can you check if data source items that broken links? – Vlad Iobagiu Jan 28 at 4:17
  • I dont see any obvious broken data sources, but Im wondering if its related to workflow. The JSS workflow is different... – Ethan Schofer Jan 28 at 13:13
  • Check all rendering associated with that page has correct data source defined and created.. – Rajesh Kumar Feb 5 at 18:47
  • Please see my above comment. I already reviewed datasources. None appear to be broken. – Ethan Schofer Feb 5 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.