1

We have upgraded the sitecore from "8.2 update 3" to "sitecore 9.3", as part of this upgrade, we performed the below activities.

1) Moved the sitecore items using serialization

2) Moved the user's data from the existing core DB into new core DB using sql migration wizard tool from below tables:

aspnet_Membership
aspnet_Profile
aspnet_Roles
aspnet_Users
aspnet_UsersInRoles
RolesInRoles

The earlier (sitecore 8.2 update 3) users created using hashAlgorithmType "SHA512"

According to that, we modified the below configurations in sitecore 9.3:

1) Open the web.config file and in the node, set the hashAlgorithmType setting to the "SHA512" value.

2) We are using Sitecore Identity, also changed the algorithm on the Sitecore Identity server.

So that we specified the algorithm in the PasswordHashAlgorithm node in the \sitecore\Sitecore.Plugin.IdentityServer\Config\identityServer.xml file.

<PasswordHashAlgorithm>SHA512</PasswordHashAlgorithm>

But the migrated users not able to log in to in sitecore 9.3, are there any additional configurations or database updates required.

5
  • Can you see the users in the user manager? Are they enabled? Did you restart the Identity server after changing the config? – Gatogordo Feb 5 '20 at 9:30
  • After making the above changes, re-started both app services, even though not able to login Sitecore CMS to cross-check the users in the user manager. – Suresh R Feb 5 '20 at 9:38
  • Did you try to reset the admin password in sql to "b"? Define the if of the admin user and try this: Update [aspnet_Membership] set [Password] = 'K8N8GUW8UiNT2mPdjvuBDH+QmvA3R61M9buVvCwFHwtDjpMzTxs34lg0uQ0azCITqh6FkUZlX4kM72lsAyuyXQ==', [PasswordSalt] = 'p5B6HOWKt0ctMZaSNXTlfw==' where [UserId] = '...' Make sure to check in the sql whether the user is not disabled. – Gatogordo Feb 5 '20 at 9:43
  • Thanks, Gatogordo, updated admin password as you suggested, now I am able to log in, verified the user manager, the migrated users are not displaying. – Suresh R Feb 5 '20 at 9:57
  • Finally issue resolved, the solution is need to update the new "ApplicationId" in all the relevant tables. – Suresh R Feb 5 '20 at 11:36

Browse other questions tagged or ask your own question.