1

We are using Sitecore commerce 9.2 and facing an issue while assigning an imported catalog from another environment to a new storefront site. Though the catalog is not associated with any other site in the current environment but still the Sitecore system throwing the below error:

'<CatalogName>' is already associated to another site

Below is the screenshot of the error message:

enter image description here Please help to resolve the issue.

3
  • can you check on /sitecore/Commerce/Catalog Management/Catalogs if the catalog is selected here ? Feb 12, 2020 at 7:54
  • I checked on /sitecore/Commerce/Catalog Management/Catalogs path and found that the catalog is not selected. But while trying to select the same and click on save it is throwing the same error as mentioned above. Feb 12, 2020 at 8:00
  • You mentioned multiple environments in your question. What do you mean with the environments? Does that mean the catalog is associated with a site?
    – James
    Feb 27, 2020 at 13:20

2 Answers 2

0

I was given the following solution by a work colleague.

  1. open the catalog (zip file) that was imported via PostMan (you may need to use 7Zip to do this as Windows explorer might complain about it being a readonly file)
  2. open Catalog.1.json
  3. find all instances of the property "ParentCatalogList" and clear the associated Guid value (so you have "ParentCatalogList":"")
  4. save Catalog.1.json back into the zip
  5. re-import the zip into Commerce using PostMan
  6. you should now be able to select the catalog within Sitecore
0

After importing the catalog, go to Sitecore content editor and open the catalog item at this path: /sitecore/content/Sites/<sitename>/Home/Catalogs , uncheck all the catalogs in the Selected Catalogs fields and save the item. enter image description here

Now, From the commerce tab in the ribbon, select refresh commerce cache, and then select back your imported Catalog at this item (/sitecore/content/Sites/<sitename>/Home/Catalogs), save the item now.

Few more things to check:

  1. If you've Sitecore default Storefront website running, then go to this path /sitecore/content/Sitecore/Storefront/Home/Catalogs and check Habitab_Master catalog is selected not your imported catalog. You can uncheck the Habitat_Master --> Save --> Reselect Habitat_Master catalog.
  2. Go to this item /sitecore/Commerce/Catalog Management/Catalogs and uncheck if any catalog is selected and save item.
  3. Go to this item
/sitecore/Commerce/Commerce Control Panel/Storefront Settings/Storefronts/<Sitename>/Catalog Configuration

and make sure Catalog should be empty. enter image description here

  1. Go to this item /sitecore/content/Sites/<SiteName>/Settings/Commerce/Catalog Configuration and make sure your imported catalog is selected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.