1

We have installed a new instance of 9.3 XP and disabled the xDB functionality.
The existing instance is 8.2 XM. As there are custom tables in core, we ran the upgrade scripts on core & master and used them instead, in the new environment.

The CMS and the live site work fine, but the personalization feature is not working.

It's a simple rule - to show content A for an anonymous user & show content B for a logged in user.

The rules used are one of these:

where the user profile includes a valid email address

where the current user is anonymous

Now the site shows both content A & B for anonymous user.

The xDB was disabled even in the existing 8.2 environment.

Any other settings to check or configure, to make this work?

1

You can use In session Personalization rules even when xDB is disabled. But make sure that

  • Open the web.config file and in the <appSettings> section, in the <add key="exmEnabled:define" value="yes"/> setting, change the value to “no”
  • Xdb.Tracking.Enabled is set to true.

Check https://doc.sitecore.com/developers/91/platform-administration-and-architecture/en/enable-disable-the-xdb-and-the-tracker.html for more info

| improve this answer | |
  • Is this something new for 9.3. Isn't exm for email experience manager. Could you please tell me how is it related. Also, we are not using exm either in the old or the new instance. – Qwerty Feb 17 at 12:48
  • 1
    you can check doc.sitecore.com/developers/91/… for more info – Himanshu Agarwal Feb 17 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.