0

My site is on a CDN and uses True-Client-IP for tracking:

  <setting name="Analytics.ForwardedRequestHttpHeader" value="True-Client-IP" />

I'm trying to test geolocation feature in production, but it only works for locations in Canada, so I'm trying to spoof my IP with a Canadian IP. I've previously used the Sitecore Analytics Testing Tool, and this worked on my local environment - though I had to use X-Forwarded-For instead of True-Client-IP to get it to work locally, but prod uses True-Client-IP as that's what's available with our CDN.

However I've set the tool to use True-Client-IP when trying to test prod but it's not working, and the test page TestIP.aspx shows my real IP address regardless of what profile I select

enter image description here

I've tried using my profile for Quebec (158.69.182.13) and Toronto (198.55.49.89) but on TestIP.aspx it always shows Tracking IP: 207.....

Does anyone know why the testing tool isn't working, or have another way to spoof my IP?

4
  • 2
    Instead of wasting time trying to work this out, I would normally just subscribe to a VPN service of your choice. This makes testing even for non technical people way easier and less of a headache. – Vincent Lui Feb 25 '20 at 22:13
  • Yupp Vincent is right. Just make sure to also test in a fresh incognito browser. – Matthew FitzGerald-Chamberlain Feb 25 '20 at 23:26
  • I have used this few times while testing the settings for GeoIP. Did you try this option? developers.google.com/web/tools/chrome-devtools/device-mode/… – Sanjeev Feb 26 '20 at 13:23
  • I tried Device Mode but that didn't work. What did finally work was using Tunnelbear – Erica Stockwell-Alpert Feb 26 '20 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.