5

If Sitecore workbox contains more than 10 items, then it start to show paging in the Draft/Awaiting Approval Section in bottom as highlighted with red rectangle in below image

enter image description here

Do anybody know how to avoid paging and show all items on Draft/Awaiting Approval Section in workbox?

7

The simplest option would be to set the 'Items per page' to a higher value (you can choose 10, 25, 50, 100 or All)

You could potentially set that as the standard by running something like Registry.SetInt("Current_User/Workbox/Page Size", 50); when someone logs in or opens the workbox, as that's the setting Sitecore checks when loading up the panel.

(PS. 999999 seems to be the value for 'All')

Edit Keep in mind this might affect the load time for the workbox if someone has a lot of items in the workbox

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.