0

We are implementing URL hardening in Azure PaaS. We have added Azure front door urls to CM app. We have updated

Sitecore.Owin.Authentication.IdentityServer.config

on CM server with new url for identity server and

Sitecore.IdentityServer.Host.xml

on identity server with the new urls for Sitecore CM. But still the identity server redirects back to the old CM server url only and not to the Azure front door url for CM. Any inputs on what are we missing here?

2
  • Are you trying to implement Azure AD login integration ? – Deepak Jena Mar 3 '20 at 12:01
  • No, we are not implementing Azure AD login integration.We are simply trying to redirect from Identity server to Azure front door url instead of CM url after login. – Ghanendra Singh Mar 4 '20 at 3:53
0

We figured out the problem. AFD url simply forwards request to the Sitecore CM webapp url. This means identity server receives request from Sitecore CM URL and not AFD url (even though we see AFD url in browser). So after user gets logged in, identity server redirects user back to Sitecore CM url only and not to AFD url. To fix this, we have added custom domain to Sitecore CM webapp instead of AFD url.

2
  • Hi, can you expand on your solution a little? As I read it, you ended up not using AFD? Or have you used the same custom domain name for both the AFD frontend URL and the app service? I can't see how that would work. – Pirate Briggs Apr 2 '20 at 8:37
  • Ah just found this answer which sounds similar: sitecore.stackexchange.com/questions/24177/… I think the missing part of the puzzle for me was overriding the host header in the AFD backend. – Pirate Briggs Apr 2 '20 at 8:52
-2

In case, you are trying to integrate azure AD authentication, you can check this Setting Up Azure Active Directory Integration with Sitecore Identity Server / Sitecore 9.1

1
  • First off this is a link only answer, and two he clearly states an Issue with Azure Frontdoor and Identity Server, which has nothing to do with AAD. – Dylan Young Mar 3 '20 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.