0

The image item on MASTER DB looks ok and no sign of errors (image below): enter image description here

After publish (smart publish / republish) the image shows error on WEB DB: enter image description here

Error: The image “https://myhost/sitecore/shell/Applications/-/media/C6E4D3A56DBE4972B58417F1AD014CCC.ashx?bc=White&db=web&h=128&mw=640&thn=1&vs=1&ts=d60017ad-2c35-465f-ab64-809b34fa5360&udi=1” cannot be displayed because it contains errors.

It looks like the BLOB field got corrupted or somehow damaged.

I have HUNDREDS of media items with same error and they work fine on another instance.

-Deleting the item on web and republishing gets the same result.

-Detaching the media and republishing gets the same result.

Does anybody know how to fix this?

  • Is there anything in the log files? – Matthew FitzGerald-Chamberlain Mar 3 at 17:07
  • @MatthewFitzGerald-Chamberlain last time I didnt see anything. I will check again after my tests this morning. – Leonardo Cunha Mar 3 at 17:12
  • 1
    The /Applications/ part in the media url doesn't look good. Do you have some custom link provider? – Marek Musielak Mar 3 at 17:21
  • @LeonardoCunha I am able to reproduce your issue (the image url is legit in Content Editor) just manually corrupting the Data value of a blob image in the Blobs table on the web database. Just republishing the corresponding media item in Sitecore fixes this fake scenario though (in SC 9.2). Which version of Sitecore are you experiencing this issue? Do you have any custom processor in the publishing pipeline that would process and modify the media items? – Alessandro Faniuolo Mar 4 at 2:08
  • Try looking for any customizations in publish related events in Sitecore (using showconfig.aspx). There is a handler probably manipulating media items on publish and corrupting the blob data in web db. – Ghanendra Singh Mar 4 at 4:42
0

Solved the problem by replacing a new WEB db.

Not sure what caused this but thanks all for the help :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.