0

Recently our client asked us to use progressive image loading for our site.

So we decided to use sitecore's image scaling/resizing to get low resolution image using sitecore image-scaling parameters, e.g.

localhost/~/media/homepage-images/x2-optimised/xyz.jpg?w=20&h=20&hash=98947F3FD40937B21D80262E6FEB7D72AF20821C

It was working fine on testing, uat, Production CM but its not working on CD environment.

I have checked all the configs nothing unusual is there(we are also using Django for image compression also tried removing this still not working), also i have tried disabling Media Protection its still not working.

Sitecore doesn't give any error it just returns the actual image not the scaled one.

Any help would be appreciated.

Update : I Checked and it seems issue of cache or may be image generation as cache key is showing

?as=False&bc=0&h=0&iar=False&mh=0&mw=0&sc=0&thn=False&w=0

in CD Environment

and in CM its shows

?as=False&bc=0&h=20&iar=False&mh=0&mw=0&sc=0&thn=False&w=20

I am not sure why this is happening, someone can help it would be much appreciated.

  • What are the urls of images? – Marek Musielak Mar 13 at 6:54
  • Hi @MarekMusielak i have edited the question, i mistakenly added HTTP:// so it got hidden. – Sunil Joshi Mar 13 at 7:08
0

This is for, who may come searching the same issue in future.

My issue was not not related to sitecore actually the issue was one of the rewrite rules,

The rewrite rule was to remove querystring so before the resize processor begins the query was remove by rewrite rule so sitecore was giving the default query string (?as=False&bc=0&h=0&iar=False&mh=0&mw=0&sc=0&thn=False&w=0) in cache, so it was looking like cache was generated wrong but it wasn't the case.

So i removed the rule and it worked like the charm.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.