1

I am trying to install Sitecore 9.3 using Solr 8.1.1, I am facing issues with Transport Layer Security [TLS 1.2] Error Message - The request was aborted: Could not create SSL/TLS secure channel. When i checked through powershell, TLS 1.2 is enabled. Solr is accesible from chrome and not from IE for the same reason.

Also, when accessed from powershell I get the same error

[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12

Invoke-WebRequest -Uri https://localhost:8985/solr/

Anybody faced this issue ?

Update : There is some security policy which is causing this issue inside my development VM... I can see smooth installation in my personal laptop... The Dev VM has got TLS 1.2 Enabled, but still i am facing issues FYI, Solr 7.5.0 was working fine in same VM

  • 1
    There could be a problem with your certificate. What steps have you taken to ensure that it was created and is a valid certificate. – Michael West Mar 18 at 19:45
  • Hey Michael, I can see the certificate is valid from Chrome... I have installed solr through SIF 2.2 for Sitecore 9.3... The wierd thing is if i open any website from IE, i can see TLS 1.2 is active from the page properties.... Only Local Solr from IE gives TLS error... This affects my sitecore 9.3 installation – karthik Mar 21 at 8:53
2

You are receiving this error, because "localhost" is not the name that you put on your certificate. Please make sure that the solr certificate has the subject name and the DNS name the same as you are using on your browser:

enter image description here

When I try to access from Powershell, I'm able to do so: enter image description here

But if I try to use 'localhost', I get the following error: enter image description here

Also, ensure that your certificate is installed on the Trusted Root directory of the machine: enter image description here

Using a browser:

enter image description here

| improve this answer | |
  • Hey Rafael, Thanks for your response. It was good to know about the suggestion. But I have same name across the certificate... I can view it as secure in Chrome.. Sadly IE is troubling me with TLS error... Main Problem is i get same error from sitecore 9.3 installer while trying to connect Solr 8.1.1..... I am pretty much sure this is a firewall related issue in my virtual Machine... because it worked pretty fine outside the VM... – karthik Mar 21 at 8:40
  • Also Solr 7.5.0 worked fine without any TLS error on same VM... Its just Solr 8.1.1 which is still troubling me – karthik Mar 21 at 8:48
0

The issue was with SSL Cipher Suite Order.

We used the following article to solve the issue:

https://medium.com/@rootsecdev/configuring-secure-cipher-suites-in-windows-server-2019-iis-7d1ff1ffe5ea

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.