1

I'm trying to set up a local instance of an existing Sitecore 9.2 site. It's using Solr 7.5.0, and I set it up through SIA. When I try to load my site I get the following error:

Could not create instance of type: Sitecore.ContentSearch.SolrProvider.SolrSearchIndex. No matching constructor was found.

I've done the following:

  1. Disabled all Lucene configs in /App_Config/Sitecore/ContentSearch
  2. Checked solr at https://localhost:8721/solr and confirmed it's running with no errors in any cores
  3. Checked each Solr index .config file (core, master, and web) and confirmed the core names match the cores in Solr
  4. Checked connectionstrings.config and confirmed solr.search is https://localhost:8721/solr

EDIT: I found the problematic file, but I'm not sure what's wrong with it:

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www.sitecore.net/xmlconfig/set/" xmlns:role="http://www.sitecore.net/xmlconfig/role/">
  <sitecore>
    <contentSearch>
      <indexConfigurations>
        <defaultSolrIndexConfiguration>
          <documentOptions>
            <fields hint="raw:AddComputedIndexField">
              <field fieldName="_content" storageType="no" indexType="tokenized">
                <patch:delete />
              </field>
            </fields>
          </documentOptions>
        </defaultSolrIndexConfiguration>
      </indexConfigurations>
      <configuration>
        <indexes>
          <index id="ac_products_master_index"
                 type="Sitecore.ContentSearch.SolrProvider.SolrSearchIndex, Sitecore.ContentSearch.SolrProvider"
                 role:require="Standalone or ContentManagement">
            <param desc="core">ac_products_master_index</param>
            <enableItemLanguageFallback>true</enableItemLanguageFallback>
          </index>
          <index id="ac_products_web_index"
                 type="Sitecore.ContentSearch.SolrProvider.SolrSearchIndex, Sitecore.ContentSearch.SolrProvider">
            <param desc="core">ac_products_web_index</param>
            <enableItemLanguageFallback>true</enableItemLanguageFallback>
          </index>
        </indexes>
      </configuration>
    </contentSearch>
  </sitecore>
</configuration>

I checked solr, and I have those two cores with matching names

1 Answer 1

1

You dont need to disable lucene indexes as this can be done from web config search app setting.

This might come from one of your custom index configurations, try to remove the custom solr index configs one by one and see which one is causing the issue.

Possible issues:

  1. One of your custom indexes uses a solr core that is not yet created locally.
  2. You might have a different version of SXA than the one supported by your sitecore version.

If you identify the custom index config that is causing the issue, you can post it here again so we can review it.

3
  • That worked - I searched for Sitecore.ContentSearch.SolrProvider.SolrSearchIndex in my App_Config folder and disabled the config files one by one until the error was resolved, so I was able to locate the issue. Thanks! Mar 31, 2020 at 15:09
  • So I found the file with the issue, but I'm not sure what's wrong in the configuration. I've added it above Mar 31, 2020 at 15:47
  • @EricaStockwell-Alpert Is that a patch file for existing custom index? it's missing other configurations such as <param desc="name">$(id)</param> and <param desc="propertyStore" Mar 31, 2020 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.