0

When I try to upload the image in Sitecore media uploader, I am getting the error "Maximum amount of data upload is NaN undefined". I got a resolution to change the maxRequestLength property value to 512000, it was working fine. but i need the maxrequestlength value to be 2147483647 for another requirement that breaks the media uploader.

<httpRuntime maxRequestLength="2147483647" executionTimeout="500000000" enableKernelOutputCache="false" relaxedUrlToFileSystemMapping="true" enableVersionHeader="false" />

Requesting help.

  • Allowing 2147483647 bytes sounds like a disaster waiting to happen. I can't imagine ever needing to store that big of a single file in the media library. I also can't image anyone ever wanting to wait for a 2 GB upload. What type of media are you trying to upload which requires this setting to change? – Michael West May 5 at 13:11
  • @MichaelWest Actually we are not storing such huge files into our media library. One of our api is using a huge size of document upload. But this setting change is required for that api which is running in the solution. – Prakash May 6 at 12:04
0

The maximum value you can pass in maxRequestLength property is 2097151. HttpRuntimeSection.MaxRequestLength Property is an int data type and the maximum positive value you can assign is 2147483647, which you want to assign here. but this value is in bytes and maxRequestLength property takes KBytes size. So you need to convert this value in KB.

2147483647 Bytes = 20,97,151.999023438 KB(floating number) ~= 20,97,151KB

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.