0

This is in Sitecore 9.1 where I have a pdf file media item in sitecore, that is browsable all good from the CM site (master DB) but when I try to browse to it on the CD site (web DB), it gave me a 404 error.

When I checked the media item on the web DB I noticed that the "Media" field was empty. I went through the logs to check for any publish errors but nothing. I still do not know why this happened.

3
  • What did Sitecore support say? – Michael West May 8 '20 at 18:22
  • Haven't heard back from them yet. – Debabrata Biswas May 11 '20 at 4:50
  • we are also facing this issue with missing blob-entries in the web database. And we found this working "detach-attach-publish" solution too. Since the project contains a large amount of media items this is not a suitable option for us :( @Debabrata Biswas Where is this bug documented? I haven't found anything yet. Do you have a reference number from the Sitecore support? – arminsandorf Aug 20 '20 at 8:01
0

Good news is I did find a solution. On the master DB, for that media item, I first downloaded the file using the download option. I then detached the file and then re-attached using the downloaded file. I then published that media item and now when i go to that media item on the web db, I can see the blob value in the "Media" field. Hope this helps anyone experiencing the same.

5
  • I've also seen cases where I had to delete the item entirely from the web database and republish from master to web. – Marcel Jun 7 '20 at 17:47
  • 1
    Sitecore has come back with a response that it is a bug in Sitecore 9.1 and have documented it. – Debabrata Biswas Jun 11 '20 at 10:04
  • @DebabrataBiswas Do you have or can you find the support case number ? i got the exact same issue – Thomas Stern Mar 18 at 8:12
  • @ThomasStern Sitecore support had provided an internal known issue number but they did not publish it. They simply suggested that we should regularly clean up the blobs table from sitecore control panel. I then ended up writing this blog "everydaysitecore.home.blog/2020/06/19/… you can automate it. – Debabrata Biswas Mar 18 at 10:24
  • @DebabrataBiswas thank you so much – Thomas Stern Mar 18 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.