0

I have project set up with Sitecore 9.3, TDS 5.7 and Glass Mapper 5.6.160.

I am getting below issue when I click on Test button on BUILD tab on the TDS project after setting Sitecore web folder and Sitecore deploy folder. I have checked the checkbox for the access guid.

Does anyone know what the issue is?

Connection Test Failure: Failed to complete test.
Exception System.Web.Services.Protocols.SoapException: Method not found: 'Void Sitecore.Data.Serialization.ItemReference..ctor(Sitecore.Data.Items.Item)'. 
   ---> System.MissingMethodException: Method not found: 'Void Sitecore.Data.Serialization.ItemReference..ctor(Sitecore.Data.Items.Item)'.
   at HedgehogDevelopment.SitecoreProject.Service.TdsService.<>c__DisplayClass2.<GetItem>b__0()
   at HedgehogDevelopment.SitecoreProject.Service.TDSExecutionContext.Wrap[T](Func`1 func)
   at HedgehogDevelopment.SitecoreProject.Service.TdsService.GetItem(String key, String sitecoreDatabase, String accessGuid, String itemIdOrPath)
   --- End of inner exception stack trace ---
   at HedgehogDevelopment.SitecoreProject.Service.TdsService.GetItem(String key, String sitecoreDatabase, String accessGuid, String itemIdOrPath) (FaultException):
1

You need to upgrade to the latest TDS version. If you check the change log you need at least 6.0.0.13 for Sitecore 9.3

| improve this answer | |
  • Thanks Mark!, FYI, on machine i have sitecore 8.1 update 3 application running . if i upgrade TDS.. will it cause any issue with existing one or not? i am using visual studio 2017. When will i install SitecoreTDS_VS2017 as per upgrade perspective, i assume installing sitecoreTDS_VS2017 will not cause any issue.. do i have to buy something for licensing point of view . or existing licensing will work.. i just have to install sitecoretds_vs2017.. and i should be ok.. does not think about licensing.? – Rajesh Kumar May 13 at 18:24
  • If you also need to use some old instance then yes, TDS might complain about versions. Either you'll need to also upgrade TDS for those other instance, or you could use VS 2017 for TDS 5.x and VS 2019 for TDS 6.x. TDS license are valid for all versions. – Mark Gibbons May 13 at 22:28
  • SitecoreTDS_VS2017 with version TDS 6.0.0.13 does not provide backward compatibility for sitecore 8.1 . if backward compatibility is there with TDS 6.0.0.13.. then i should be able to use both instance on the same machine with VS2017 – Rajesh Kumar May 14 at 6:35
  • TDS supports Sitecore 7.0+ hedgehogdevelopment.github.io/tds/… – Mark Gibbons May 19 at 3:25
  • I upgraded TDS, I did not see any issue. It is working fine. Thanks Mark!! – Rajesh Kumar May 19 at 6:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.