0

I have a JSS Tenant and Site working and Running. I created another Jss Tenant and JSS Site in it using Sitecore 9.3. Created a JSS App as i did before.

I created a new API Key for my second Site. Everything worked when I deployed it first time. I got site up and running. but then again when I tried to deploy its showing

Unexpected response from import service: Status message: Forbidden
 Body: Deployment not allowed; no secret set.

deployment secret is set, Graphql Api is working as well. I can't find what the problem is. I even tried to use first API key and again setup the JSS app to get new deployment Secret but nothing worked. Has anyone encountered this issue before?

Thanks in advance.

  • Let's see a copy of your deploy secret config. Does the name attribute alongside your deploymentSecret attribute match the name of your new site? Could this be a copy paste issue somewhere? Have you tried using the debugSecurity functionality as outlined at the bottom of this page? jss.sitecore.com/docs/fundamentals/services/app-configuration – Marcel May 22 at 12:49
  • Thanks for your comment @marcel. yes it does match and I do have same deployment Secret in both the places(app config and Sitecore site Settings). I did not try debugSecurity though. Will try it. – Kanchan May 22 at 14:11
0

I was able to resolve this particular deployment issue. I created new SXA Tenant and site in the existing sitecore instance and I already had one SXA Tenant(app-name1), I created new JSS app and deployed. I also copied app-name2.config from \app-name2\sitecore\config to sitecore site folder JssDemosc.dev.local\App_Config\Include\zzz. Now I have 2 configs app-name1.config and app-name2.config, and they both have

<site>  and <javaScriptServices> 

settings in them. now I could not deploy any of the Jss app. I deleted <javaScriptServices> from app-name2.config and deployment started working for both of them and files are being deployed in the correct locations.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.