0

I have WFFM installed on Sitcore 8.2 update 3. I have created a contact form with the usual fields and created a template with the same fields so that I can create an item in Sitecore to see the results of the form submissions.

I added "Create Item" action to the save the submitted information into an item of the template and mapped the fields to the fields in the template. It is the only action other than the default goal action that it adds automatically.

When I submit the form, it seems to work fine, but no item is ever created. There are no error in the main log either. I tried giving anonymous user read/write/create access to the destination, but that did no good (and I'm logged in as admin anyway).

I tried increasing my log detail to DEBUG and it does generate the following in the log file:

2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Could not find node [config]  
2300 17:38:35 DEBUG Item does not have the expected definition template. Item: '/sitecore/system/Settings/Analytics/Page Events/Submit Success Event', expected template: '{475E9026-333F-432D-A4DC-52E03B75CB6B}'  
2300 17:38:35 DEBUG Item does not have the expected definition template. Item: '/sitecore/system/Settings/Analytics/Page Events/Form Submit', expected template: '{475E9026-333F-432D-A4DC-52E03B75CB6B}'  
2300 17:38:36 INFO  Cache created: 'wfm:initialvalues' (max size: 100KB, running total: 2468MB)  
2300 17:38:36 DEBUG [Sitecore Mvc]: Profile > Long running RazorViewEngine.FindPartialView(Index) - 2ms  
2300 17:38:36 DEBUG Session is in TRANSIENT MODE. ReleaseContact processor is skipped  
4756 17:38:36 DEBUG [Analytics]: Tracker.IsActive == false. EndAnalytics pipeline is terminated  
4756 17:38:36 DEBUG Tracker is not initialized. ReleaseContact processor is skipped  
2300 17:38:36 DEBUG [Analytics]: Tracker.IsActive == false. EndAnalytics pipeline is terminated  
2300 17:38:36 DEBUG Tracker is not initialized. ReleaseContact processor is skipped  
2300 17:38:36 DEBUG [Analytics]: Tracker.IsActive == false. EndAnalytics pipeline is terminated  
2300 17:38:36 DEBUG Tracker is not initialized. ReleaseContact processor is skipped  
4756 17:38:36 DEBUG [Analytics]: Tracker.IsActive == false. EndAnalytics pipeline is terminated  
4756 17:38:36 DEBUG Tracker is not initialized. ReleaseContact processor is skipped  
4756 17:38:36 DEBUG [Analytics]: Tracker.IsActive == false. EndAnalytics pipeline is terminated  
4756 17:38:36 DEBUG Tracker is not initialized. ReleaseContact processor is skipped  
2300 17:38:36 DEBUG [Analytics]: Tracker.IsActive == false. EndAnalytics pipeline is terminated  
2300 17:38:36 DEBUG Tracker is not initialized. ReleaseContact processor is skipped  
4756 17:38:36 DEBUG [Analytics]: Tracker.IsActive == false. EndAnalytics pipeline is terminated  
4756 17:38:36 DEBUG Tracker is not initialized. ReleaseContact processor is skipped  
3476 17:38:41 DEBUG [Analytics]: Created new agent instance: 'aggregation/aggregator'.  
3264 17:38:41 DEBUG [Analytics]: Created new agent instance: 'aggregation/historyWorker'.  
4724 17:38:41 DEBUG [Analytics]: Created new agent instance: 'aggregation/rebuildAgent'.  
4740 17:38:41 DEBUG [Analytics]: Created new agent instance: 'aggregation/contactProcessing'.  
1260 17:38:41 DEBUG [Analytics]: Created new agent instance: 'aggregation/automationRangeManager'.  
4448 17:38:41 DEBUG [Analytics]: Created new agent instance: 'processing/taskAgent'.  
5088 17:38:41 DEBUG [Analytics]: Created new agent instance: 'aggregation/historyCompletionCheck'.  
5088 17:38:41 DEBUG [Analytics]: MongoDbHistoryTaskManager - deactivated history task.  
2428 17:38:41 DEBUG [Analytics]: Created new agent instance: 'aggregation/automationCleanupService'.  
3988 17:38:41 DEBUG [Analytics]: Created new agent instance: 'aggregation/pathAnalyzerLiveAgent'.

I'm not sure where to go from here, please help!

  • I also tried the "Add Contact to Contact List" action and it did nothing, just like the Create Item action. – Michael Jun 1 at 16:36
0

Apparently, you cannot test the form in preview but it must be published to the web server to function (per Sitecore support). Once I published the form and tested from CD server, it worked fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.