1

After a particular template is deployed during a release, page level components are getting bumped to the bottom of the components list on page final layout. We've pulled that template from getting deployed so this has stopped happening, but the next time we need to deploy that template it's going to cause the same issue.

For example:

Page final layout BEFORE release:

TemplateLevelComponentA
PageLevelComponentB
TemplateLevelComponentC

Page final layout AFTER release:

TemplateLevelComponentA
TemplateLevelComponentC
PageLevelComponentB

Also, not sure if this is related but the shared layout on the template contains only components from base templates, the final layout contains components for the page (plus the components from shared). I'm learning not everyone has their templates set up this way.

7
  • You would need to provide more details on what the deployment is doing. – Michael West Jun 10 '20 at 18:01
  • Hi Michael--I tweaked my post to make it a little more clear. Thanks! – ecorry Jun 10 '20 at 18:20
  • @ecorry Does the source where the template you are deploying has the correct order on the presentation details? For example, if you are packaging the item from Local to install on Production, does the version on the local instance in proper order? – Hishaam Namooya Jun 10 '20 at 18:22
  • Hi Hishaam--Yes, the installed template has the same version and the same order as production. Thanks! – ecorry Jun 10 '20 at 18:28
  • This template does not have any inheritance that contains a rendering on it? – Hishaam Namooya Jun 10 '20 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.