1

We migrated our Sitecore 8.2 initial release to Sitecore 9.2.

In sitecore 8.2 initial release we had sitecore users synched with AD(using LDAP )

Since Sitecore 9.2 will not support AD, we removed all the configuration of LDAP.

When we login to core db -- [aspnet_Users] table, we are able to see our users(about 150 users)

But these users are not showing in the User Manager wizard.

  • Hi @PVM what was your migration process from Sitecore 8.2 to Sitecore 9.2? Did you apply core db migration scripts – Julius A Jun 11 at 17:24
  • 1
    Hi @JuliusA, yes we applied the core db migration scripts before 9.2 upgrade. – PVM Jun 12 at 2:56
2

Depending on your upgrade process, either way it seems your aspnet_Users table doesn't have matching records in aspnet_Membership table. This is where issue lies.

To verify use the SQL Query below

select U.* from aspnet_Users as U
JOIN aspnet_Membership as M on U.UserId = M.UserId

The resulting users above should appear in the User Manager screen.

Please note in Sitecore 9.x there is default implementation in Identity Server to ensure usernames are unique, as we can use federated authentication. Worth validating if the usernames after your upgrade are unique. I have blogged about this previously and worth having a read.

| improve this answer | |
  • yes the user detail are not there in the aspnet_Membership table. Is there a way to insert the user detail only in the aspnet_Membership table – PVM Jun 15 at 14:15
  • Yes, you can script I believe. However, worth checking why they were not migrated in the first place. If you insert new entries, it may mean users have to reset their passwords for example – Julius A Jun 16 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.