3

When trying to install Sitecore 9.3 using the new Sitecore Install Assistant, SOLR fails to install with the following error:

[------------------------ DownloadSolr : DownloadFile ------------------------]
[DownloadSolr]:[Download] http://archive.apache.org/dist/lucene/solr/8.1.1/solr-8.1.1.zip => C:\Users\...\AppData\Local\Temp\solr.zip

[-------------------------- UnpackSolr : ExpandArchive -----------------------]

[---------------------------- MoveSolr : MoveItem ----------------------------]
Access to the path 'C:\Users\...\AppData\Local\Temp\solr-8.1.1\contrib' is denied.

I'm running the installer as an admin but that seems to make no difference.

1
  • Can you try specifying the Install Path to some other drive other than C drive? Commented Jun 16, 2020 at 7:16

4 Answers 4

3

Try specifying the value of the Install Path to some other drive other than C drive in the Install Solr step while running the Sitecore Installation Assistant.

Some paths in C Drive may cause permission issues unless you have granted access in the folder's properties in file explorer.

enter image description here

1

Looking at Solr-SingleDeveloper.json. There is a parameter named TempLocation:

"TempLocation": {
        "Type": "String",
        "Description": "Alternative location to save downloads. If left on the default $Env:Temp will be used.",
        "DefaultValue": "SIF-Default",
        "Validate": "[TestPath(variable('Temp.Location'))]"
    }

If you open a PowerShell console and type $Env:Temp I'm sure you'll see the same path you listed in your question.

This parameter begins in XP0-SingleDeveloper.json named PackagesTempLocation. You should be able to add a new parameter in XP0-SingleDeveloper.ps1 to target this:

XP0-SingleDeveloper.ps1

# Install XP0 via combined partials file.
$singleDeveloperParams = @{
  Path = "$SCInstallRoot\XP0-SingleDeveloper.json"
  SqlServer = $SqlServer
  ...
  AllowedCorsOrigins = $AllowedCorsOrigins
  SitePhysicalRoot = $SitePhysicalRoot
  PackagesTempLocation = "C:\Your\New\Location"
}
0

I was also facing the same issue. Please run the same Sitecore setup after deleting these 2 folders - C:\Users\[yourusername]\AppData\Local\Temp\solr-8.1.1 and C:\Solr.

Note :- Folder-"AppData" is hidden by default in Windows File Explorer.

Thanks, Kalpesh

0

access to path denied

I had to change the templocation like jrap suggested but I did it on D drive because I tried like in the image below on C drive and still I had the same issue. After creating the same folder on D drive also gave permission to the folder from the Security tab as full control for the user I logged on to the machine and Everyone it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.