0

I am using the provided ARM Templates to deploy a Sitecore 9.3 XP Scaled topology to Azure PaaS, and then planning to add some adjustments. It all went mostly fine, but I'm stuck now when I tried to add SXA+PS as a module. Following the documentation, I added this snippet to the azuredeploy.parameters.json file:

"modules": {
  "value": {
    "items": [
      {
        "name": "sxa",
        "templateLink": "",
        "parameters": {
          "cdSxaMsDeployPackageUrl": "",
          "cmSxaMsDeployPackageUrl": "",
          "speMsDeployPackageUrl": ""
        }
      },
      {
        "name": "bootloader",
        "templateLink": "",
        "parameters": {
          "msDeployPackageUrl": ""
        }
      }
    ]
  }
}

and populated with the right values. I do have the right templates and scwdp packages uploaded to my blob storage, just the same as the other templates and packages that are actually working.

However, once I add the "modules", I am getting this error from the azuredeploy.json template, which is not a valid template anymore:

New-AzResourceGroupDeployment : 12:13:25 - Error: Code=InvalidTemplate; Message=Deployment template validation failed: 'The template variable 'dependencies' is not valid: The language expression property 'items' doesn't exist, available properties are 'CliXml'.. Please see https://aka.ms/arm-template-expressions for usage details.'.

Which is referring to this variable in the main template:

"dependencies": "[concat(variables('defaultDependency'), parameters('modules').items)]"

which I haven't changed, and seems to be just like that from the previous versions. Nothing came up from googling this. Any idea what am I doing wrong? Many thanks in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.