0

We recently upgraded sitecore 8.2 to 9.2. while analyzing the pipeline profiling for 30 min, we could see the following sitecore jobs were executed 87 time in 8.2 instance and 200 time in 9.2 instance. This also exist in new vanilla instance of sitecore 9.2.

Is there any way to limit the execution frequency of these jobs in sitecore 9.2

Sitecore.Jobs.JobRunner.SignalStart
Sitecore.Jobs.JobRunner.SetPriority
Sitecore.Jobs.JobRunner.SetSecurity
Sitecore.Jobs.JobRunner.SetContextUser
Sitecore.Jobs.JobRunner.InitializeContext
Sitecore.Jobs.JobRunner.RunMethod
Sitecore.Jobs.JobRunner.ResetSecurity
Sitecore.Jobs.JobRunner.SignalEnd

  • Are the agents configured the same between the two instances? – Michael West Jul 12 '20 at 9:33
  • @MichaelWest, yes it is same – PVM Jul 12 '20 at 11:24
  • @MichaelWest I checked in the item /sitecore/system/Tasks. is there any config file I need to check . can you share the details please. – PVM Jul 12 '20 at 11:33
  • Check showconfig.aspx – Michael West Jul 12 '20 at 15:24
  • @MichaelWest , We found there was a job in Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config that runs for every 1 min <agent type="Sitecore.ContentSearch.SolrProvider.Agents.IndexingStateSwitcher, Sitecore.ContentSearch.SolrProvider" method="Run" interval="00:01:00" patch:source="Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config"/> once we commented the problem was solved. – PVM Jul 15 '20 at 19:57
1

The JobRunner processors in the Job pipeline are responsible to manage the execution of queued jobs, like indexing jobs.

You can control their execution frequency modifying the value of the Jobs.QueueProcessingInterval setting, set to 2 seconds by default:

<!--  JOB QUEUE INTERVAL
            Gets the interval between the JobManager checking its queue for pending actions.
            Default value: "00:00:02" (2 seconds)
      -->
<setting name="Jobs.QueueProcessingInterval" value="00:00:02" />

This setting has the same default value in both Sitecore 8.2 and Sitecore 9.2 vanilla instances. If you are seeing more executions of these processors is because Sitecore 9.2 has more jobs that need to be executed than Sitecore 8.2.

Be aware that modifying this setting could affect all jobs interval execution. If you want to reduce the execution frequency of a specific job, you should instead modify the interval execution settings of that particular job (for example for an indexing job, you could change the indexing strategy to use an interval strategy and control the frequency tuning its interval parameter).

  • thanks for the input. apart from the above we found the following job was running for every min <agent type="Sitecore.ContentSearch.SolrProvider.Agents.IndexingStateSwitcher, Sitecore.ContentSearch.SolrProvider" method="Run" interval="00:01:00" patch:source="Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config"/> once we commented the problem was solved. – PVM Jul 15 '20 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.