2

I am using Sitecore 9.3 with SPS 4.2. Publish is working fine but "Publish Related Items" is not working. After digging into some documents and Sitecore Support I came to know that I need to change the Links databases into SPS configuration Core to Web.

I made the change and after that, I am continuously getting errors -

In browser console I can see - /sitecore/api/ssc/publishing/maintenance/0/IsRunning - Response status code does not indicate success: 502 (Bad Gateway).

And on Publish window and Publishing Dashboard getting - Publishing Service not working Contact Administrator.

I am changing back to Core it again start working but Publish Related Items not working in this case.

Anyone faced any similar issue with SPS? Any help would be appreciated.

6
  • did you try by enabling the "sc.publishing.relateditems.xml" at sitecorepublishing\config\sitecore\publishing? Jul 29, 2020 at 17:57
  • Yes I did... didn't work Jul 29, 2020 at 17:59
  • Is it not working after full republish? SPS does not publish items if one of their parents is not published.
    – x3mxray
    Jul 30, 2020 at 10:14
  • @x3mxray - No It is not working if I am publishing Single Item with Options Selected Publish Related Items ... in this case it is not publishing related items Jul 30, 2020 at 12:16
  • @YogeshSharma, have you found what the problem was? We're facing similar issue.
    – grg
    Nov 16, 2020 at 15:30

1 Answer 1

1

Sitecore stores Links database/table to Core db in On-Premise environment, but in a scaled environment, it stores Links table to Web database. By default, "Publishing Service" points to Core database so you need to change this setting to Web.

File: In sitecore publishing webApp: sitecorepublishing\config\sitecore\publishing\sc.publishing.xml

<DefaultConnectionFactory>
      <Options>
        <Connections>
          <Links>
          <Type>Sitecore.Framework.Publishing.Data.AdoNet.SqlDatabaseConnection, Sitecore.Framework.Publishing.Data</Type>
            <LifeTime>Transient</LifeTime>
            <Options>
              <ConnectionString>${Sitecore:Publishing:ConnectionStrings:Web}</ConnectionString>
              <DefaultCommandTimeout>120</DefaultCommandTimeout>
              <Behaviours>
                <backend>sql-backend-default</backend>
                <api>sql-api-default</api>
              </Behaviours>
            </Options>
          </Links>

You can refer Sitecore.Config file to verify your CM configuration.

<sc.variable name="defaultLinkDatabaseConnectionStringName" value="core" />
  <sc.variable name="defaultLinkDatabaseConnectionStringName" role:require="ContentDelivery or ContentManagement">
    <patch:attribute name="value">web</patch:attribute>
  </sc.variable>

<LinkDatabase type="Sitecore.Data.$(database).$(database)LinkDatabase, Sitecore.Kernel">
<param connectionStringName="$(defaultLinkDatabaseConnectionStringName)" />

Finally enable file "sc.publishing.relateditems.xml" at sitecorepublishing\config\sitecore\publishing

Note 1: You might face issue with schema after making above changes, so in order to resolve that issue you need to re-run update schema command again, irrespective of previous schema state,

Command 1:.\Sitecore.Framework.Publishing.Host.exe schema list

Command 2:.\Sitecore.Framework.Publishing.Host.exe schema upgrade --force

Note 2: Authors must select the Publish Related items checkbox before publishing.

Note 3: Sitecore only publishes those related items, which are referenced by the selected item, but not those, which refer to that selected item.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.