2

Installed fresh Sitecore 10 and trying to use Sitecore CLI combined with native Sitecore Content Serialization. When executing next command

dotnet sitecore ser pull

I get an error message

Make sure the GraphQL service is installed and available.

Anyone has an idea on what's missing?

0
3

Make sure you've installed the Sitecore Management Services module.

It's listed as a pre-req here: https://doc.sitecore.com/developers/100/developer-tools/en/install-sitecore-command-line-interface.html

dead link on the documentation website was supposed to lead me here: https://dev.sitecore.net/Downloads/Sitecore_CLI/2x/Sitecore_CLI_200.aspx

1
  • Hi there, I already installed the Sitecore Management Services package but still get "Make sure the GraphQL service is installed and available." I really do not know what happened. Any help!? Please, – Tuananhcwrs Oct 16 '20 at 3:58
5

We also faced a similar issue so we added https:// in our instance name in user.json (\.sitecore\user.json) and then tried again and it worked for us. Make sure you have https:// in your instance, then try.

"host": "https://sc10sc.dev.local",
"authority": "https://sc10identityserver.dev.local"
2
  • solved thank you – Osaid Alaraj Dec 7 '20 at 12:35
  • That solved my problem. Not sure what causes sitecore CLI saved http:// instead of https:// in user.json file after login. Ton of thanks! – Tuananhcwrs Dec 14 '20 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.