7

Installed fresh Sitecore 10 and trying to use Sitecore CLI combined with native Sitecore Content Serialization. When executing next command

dotnet sitecore ser pull

I get an error message

Make sure the GraphQL service is installed and available.

Anyone has an idea on what's missing?

0

7 Answers 7

6

Make sure you've installed the Sitecore Management Services module.

It's listed as a pre-req here: https://doc.sitecore.com/developers/100/developer-tools/en/install-sitecore-command-line-interface.html

dead link on the documentation website was supposed to lead me here: https://dev.sitecore.net/Downloads/Sitecore_CLI/2x/Sitecore_CLI_200.aspx

3
  • Hi there, I already installed the Sitecore Management Services package but still get "Make sure the GraphQL service is installed and available." I really do not know what happened. Any help!? Please, Oct 16, 2020 at 3:58
  • This doesn't seem like the correct answer to this issue. I am receiving the same error message after installing the Sitecore CLI, as listed in this link. Apr 28, 2022 at 16:17
  • Been through all of these and none of them worked for me. I have installed and re-installed Sitecore CLI, but getting same error message. My http settings are correct as well both identity server and website are "https". Any other help or suggestions? Oct 13, 2022 at 17:33
9

We also faced a similar issue so we added https:// in our instance name in user.json (\.sitecore\user.json) and then tried again and it worked for us. Make sure you have https:// in your instance, then try.

"host": "https://sc10sc.dev.local",
"authority": "https://sc10identityserver.dev.local"
3
  • solved thank you Dec 7, 2020 at 12:35
  • That solved my problem. Not sure what causes sitecore CLI saved http:// instead of https:// in user.json file after login. Ton of thanks! Dec 14, 2020 at 8:20
  • Been through all of these and none of them worked for me. I have installed and re-installed Sitecore CLI, but getting same error message. My http settings are correct as well both identity server and website are "https". Any other help or suggestions? Oct 14, 2022 at 19:33
1

This is an extension of the answer by Gaurav.

The Sitecore CLI saves the values in user.json based on the values that you provide in login command.

dotnet sitecore login --authority https://id.dockerbase.localhost --cm https://cm.dockerbase.localhost --allow-write true

My issue was that I had given http in CM url.

1
  • Yup I did the same thing. Thanks for this answer! Apr 11, 2023 at 15:40
1

I got that very error message these days when running dotnet sitecore ser pull or dotnet sitecore ser push.

I was able to fix it by reinstalling in CM the Sitecore.ManagementServices package from https://dev.sitecore.net/Downloads/Sitecore_CLI/5x/Sitecore_CLI_5125.aspx

You can follow these instructions https://doc.sitecore.com/xp/en/developers/102/developer-tools/sitecore-management-services.html

Be sure to install the right package, compatible with Sitecore CLI version you installed. I had previously installed the wrong package, installing the correct one fixed the issue.

0

If you are getting this error for non-interactive login, then make sure that the source & target env's Dotnet tool version is the same. you can find this info under (/.config/dotnet-tools.json)

Eg:

{
  "version": 1,
  "isRoot": true,
  "tools": {
    "sitecore.cli": {
      "version": "4.1.0",
      "commands": [
        "sitecore"
      ]
    }
  }
}
0

In my case it turned out to be Sitecore topology mismatch.

Explanation : I was using Sitecore Content Serialization (SCS) 4.0.0 for Sitecore 10.2 XM and in the docker compose XM override file, for CM image, Management services argument, I was passing XP image reference scr.sitecore.com/sxp/modules/sitecore-management-services-xp1-assets:4.0.0-1809 Once I changed it to scr.sitecore.com/sxp/modules/sitecore-management-services-xm1-assets:4.0.0-1809 , I was able to successfully use SCS.

0

In my case I had to fix my configuration by connecting XM Cloud and local environments.

dotnet sitecore cloud environment connect -id <environment-id> --allow-write true

dotnet sitecore connect --ref xmcloud --cm https://xmcloudcm.localhost --allow-write true -n local

Details are described here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.