5

Trying to install Sitecore 10 using SIA (as I'm having issues with the container installation getting started template). I'm following this blog post: http://madhuanbalagan.com/installing-sitecore-10-using-sia

enter image description here

Detailed error message is:

[-------------- XConnectXP0_InstallWDP : WebDeploy ---------------------------]
[WebDeploy]:[Path] C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe
Error Code: ERROR_SQL_EXECUTION_FAILURE
More Information: An error occurred during execution of the database script. The error occurred between the following lines of the script: "10" and "18". The verbose log might have more information about the error. The command started with the following:

"DECLARE @containmentLevel tinyint = CONVERT(tiny"
 Execution Timeout Expired.  The timeout period elapsed prior to completion of the operation or the server is not responding. http://go.microsoft.com/fwlink/?LinkId=178587  Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_SQL_EXECUTION_FAILURE.

Error: Execution Timeout Expired.  The timeout period elapsed prior to completion of the operation or the server is not responding.

Error: The wait operation timed out

Error count: 1.

Unfortunately, the link takes me to the Microsoft site with very little information. This is the second time I have gotten this error. The first time it actually created the Sitecore 10 databases as I had to delete them before I could run the installation again. This time however no databases but it has verified that the credentials supplied for the local SQL server worked ok.

Confirming validation passed relating to connection to SQL server. enter image description here

Rerunning installation gives me: enter image description here

Update: So now that I've upgraded my SQL server I'm getting a new error: enter image description here

Why would it be looking in this folder given that it wasn't related at all to the location or service name specified?

enter image description here

Even after stopping my other solr service - it's still looking in this location.

Here's the folder specified on the solr settings screen: enter image description here

Here is the referenced service pointing to that folder: enter image description here

7
  • Is the correct instance of SQL server used? Either the path is incorrect or incompatible version? Aug 10, 2020 at 3:34
  • Initially it had the wrong path for sql, so when it validated the connection to SQL it failed, but I fixed that and validation passed and it seemed ok. I would have thought sql2016 would be compatible. In a previous attempt it did create all the databases but still had the above error
    – Jen
    Aug 10, 2020 at 3:38
  • 3
    Looks like 2017 is the minimum requirement. There may be a technical reason for it so may be worth upgrading sooner than later. kb.sitecore.net/articles/087164 Aug 10, 2020 at 3:40
  • Thanks for the suggestion - have fallen into the trap of corporate laptop and sticking to the project specific sql versions. Will try upgrading and re-installing. Shame the validation doesn't check that if that is indeed the case.
    – Jen
    Aug 10, 2020 at 3:58
  • @MichaelWest Got over my sql hurdle but now it seems to be creating solr cores whilst ignoring the solr values I provided as part of the install. Nothing obvious jumps out in the json files but it seems to be grabbing the path from my "solr" service which is older (even if I stop it)
    – Jen
    Aug 10, 2020 at 5:37

1 Answer 1

3

Looks like two things tripped me up:

  • Not having the right version of SQL server (2017 minimum)
  • Something went wrong with the creation of the solr service using the installer - even though it looked like it had installed/was running ok. Manually setting up the service and referencing that in the installer worked like a charm.

For anyone needing a reminder on how to install solr with SSL using nssm you can follow: https://medium.com/redhotminute-australia/setting-up-solr-with-ssl-for-sitecore-9-acdf009edd93

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.